Results 1 to 2 of 2

Thread: [SOLVED] Problem with Zimbra mobile after upgrade from 5.0.18GA to 6.0.1GA

Threaded View

  1. #1
    Join Date
    Feb 2009
    Posts
    22
    Rep Power
    6

    Default [SOLVED] Problem with Zimbra mobile after upgrade from 5.0.18GA to 6.0.1GA

    Hello,

    I have a problem with Zimbra Mobile/ActiveSync on Sony Ericsson P1i. On Zimbra 5.0.18GA is anythink ok, but on Zimbra 6.0.1GA I get this error on mobile phone:

    ActiveSync_ReportError():0x7370D02

    In /opt/zimbra/log/sync.log I see this (ip address and username is removed):
    2009-10-07 22:37:57,166 INFO [btpool0-2008] [ip=***here was ip address of mobile phone***;] sync - POST Microsoft-Server-ActiveSync?User=***here was user name***&DeviceId=357033014331961&DeviceType=RoadSy ncClient&Cmd=Sync
    2009-10-07 22:37:57,251 INFO [btpool0-2008] [ip=***here was ip address of mobile phone***;] sync - DeviceID=357033014331961; DeviceType=RoadSyncClient; UA=Microsoft-SmartPhone/3.0 SonyEricssonP1i/R100 Profile/MIDP-2.0 Configuration/CLDC-1.1; Protocol=2.5; PolicyKey=0
    2009-10-07 22:37:57,273 WARN [btpool0-2008] [name=***here was user name***;mid=3;ip=***here was ip address of mobile phone***;Cmd=Sync;DeviceID=357033014331961;] sync - Mailbox access exception
    com.zimbra.common.service.ServiceException: system failure: failed to add device 357033014331961
    ExceptionId:btpool0-2008:1254947877273:ccc0311d06833050
    Code:service.FAILURE
    at com.zimbra.common.service.ServiceException.FAILURE (ServiceException.java:251)
    at com.zimbra.zimbrasync.Device.addDevice(Device.java :157)
    at com.zimbra.zimbrasync.ProvisionManager.checkProvis ioning(ProvisionManager.java:17)
    at com.zimbra.zimbrasync.ZimbraSyncServlet.processPos tRequest(ZimbraSyncServlet.java:346)
    at com.zimbra.zimbrasync.ZimbraSyncServlet.doPost(Zim braSyncServlet.java:275)
    at com.zimbra.zimbrasync.ZimbraSync$HttpHandler.doPos t(ZimbraSync.java:33)
    at com.zimbra.cs.extension.ExtensionDispatcherServlet .service(ExtensionDispatcherServlet.java:99)
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:820)
    at org.mortbay.jetty.servlet.ServletHolder.handle(Ser vletHolder.java:502)
    at org.mortbay.jetty.servlet.ServletHandler$CachedCha in.doFilter(ServletHandler.java:1148)
    at org.mortbay.servlet.UserAgentFilter.doFilter(UserA gentFilter.java:81)
    at org.mortbay.servlet.GzipFilter.doFilter(GzipFilter .java:145)
    at org.mortbay.jetty.servlet.ServletHandler$CachedCha in.doFilter(ServletHandler.java:1139)
    at org.mortbay.jetty.servlet.ServletHandler.handle(Se rvletHandler.java:378)
    at org.mortbay.jetty.security.SecurityHandler.handle( SecurityHandler.java:216)
    at org.mortbay.jetty.servlet.SessionHandler.handle(Se ssionHandler.java:181)
    at org.mortbay.jetty.handler.ContextHandler.handle(Co ntextHandler.java:765)
    at org.mortbay.jetty.webapp.WebAppContext.handle(WebA ppContext.java:417)
    at org.mortbay.jetty.handler.ContextHandlerCollection .handle(ContextHandlerCollection.java:230)
    at org.mortbay.jetty.handler.HandlerCollection.handle (HandlerCollection.java:114)
    at org.mortbay.jetty.handler.HandlerWrapper.handle(Ha ndlerWrapper.java:152)
    at org.mortbay.jetty.handler.rewrite.RewriteHandler.h andle(RewriteHandler.java:230)
    at org.mortbay.jetty.handler.HandlerWrapper.handle(Ha ndlerWrapper.java:152)
    at org.mortbay.jetty.Server.handle(Server.java:324)
    at org.mortbay.jetty.HttpConnection.handleRequest(Htt pConnection.java:517)
    at org.mortbay.jetty.HttpConnection$RequestHandler.co ntent(HttpConnection.java:868)
    at org.mortbay.jetty.HttpParser.parseNext(HttpParser. java:747)
    at org.mortbay.jetty.HttpParser.parseAvailable(HttpPa rser.java:212)
    at org.mortbay.jetty.HttpConnection.handle(HttpConnec tion.java:386)
    at org.mortbay.io.nio.SelectChannelEndPoint.run(Selec tChannelEndPoint.java:409)
    at org.mortbay.thread.BoundedThreadPool$PoolThread.ru n(BoundedThreadPool.java:451)
    Caused by: com.mysql.jdbc.exceptions.MySQLDataException: Data truncation: Data too long for column 'user_agent' at row 1

    Query being executed when exception was thrown:

    INSERT INTO mobile_devices (mailbox_id, device_id, device_type, user_agent, protocol_version, provisionable, status, policy_key, first_req_received) VALUES (3, '357033014331961', 'RoadSyncClient', 'Microsoft-SmartPhone/3.0 SonyEricssonP1i/R100 Profile/MIDP-2.0 Configuration/CLDC-1.1', '2.5', 1, 0, 246013427, 1254947877)
    at com.mysql.jdbc.MysqlIO.checkErrorPacket(MysqlIO.ja va:2983)
    at com.mysql.jdbc.MysqlIO.sendCommand(MysqlIO.java:16 31)
    at com.mysql.jdbc.MysqlIO.sqlQueryDirect(MysqlIO.java :1723)
    at com.mysql.jdbc.Connection.execSQL(Connection.java: 3283)
    at com.mysql.jdbc.PreparedStatement.executeInternal(P reparedStatement.java:1332)
    at com.mysql.jdbc.PreparedStatement.executeUpdate(Pre paredStatement.java:1604)
    at com.mysql.jdbc.PreparedStatement.executeUpdate(Pre paredStatement.java:1519)
    at com.mysql.jdbc.PreparedStatement.executeUpdate(Pre paredStatement.java:1504)
    at com.zimbra.cs.db.DebugPreparedStatement.executeUpd ate(DebugPreparedStatement.java:170)
    at org.apache.commons.dbcp.DelegatingPreparedStatemen t.executeUpdate(DelegatingPreparedStatement.java:2 33)
    at com.zimbra.zimbrasync.Device.addDevice(Device.java :153)
    ... 29 more
    2009-10-07 22:37:57,274 INFO [btpool0-2008] [name=***here was user name***;mid=3;ip=***here was ip address of mobile phone***;Cmd=Sync;DeviceID=357033014331961;] sync - HTTP/1.1 500 Mailbox access error
    Zimbra Mobile with iPhone work fine.

    It's seem like a problem with long name of user_agent.

    Any idea how to fix this problem?



    EDIT: Solved. Just upgrade on Sony Ericsson P1i to last version of active sync (Sony Ericsson - Support - Softwaredownloads - Detailed - Exchangeactivesync - P1i).
    Last edited by creagel; 10-14-2009 at 02:52 AM.

Similar Threads

  1. Replies: 21
    Last Post: 02-04-2010, 09:06 AM
  2. Replies: 31
    Last Post: 12-15-2007, 08:05 PM
  3. zmtlsctl give LDAP error
    By sourcehound in forum Administrators
    Replies: 5
    Last Post: 03-11-2007, 03:48 PM
  4. 4.5 Upgrade failure
    By brained in forum Installation
    Replies: 9
    Last Post: 03-03-2007, 02:30 PM
  5. huge log size
    By rmvg in forum Administrators
    Replies: 5
    Last Post: 01-02-2007, 09:39 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •