Results 1 to 5 of 5

Thread: [SOLVED] iPhone/self-signed cert

Hybrid View

  1. #1
    Join Date
    Aug 2008
    Location
    St Pete FL USA
    Posts
    392
    Rep Power
    7

    Default [SOLVED] iPhone/self-signed cert

    Has anyone found any way to get a self-signed cert onto an iPhone that does *not* involve building a whole ecosystem around the iPhone Configuration Utility?

    Would browsing to the admin console from the phone and accepting the cert do it?

    I only have 5 of the things, and I have enough software ecologies to mind-meld with already thankyouverymuch...
    Jay R. Ashworth - ZCS 6.0.9CE/CentOS5 - St Pete FL US - Music - Blog - Photography - IANAL - IAAMA
    Try to Ask Questions The Smart Way -- you'll get better answers.

    Put your product and version in your profile/signature - All opinions strictly my own, even though I have an employer these days.
    If you [SOLVE] something, please tell everyone how for the archives
    And, please... read what people write, and answer the questions they asked, not the ones they didn't.

  2. #2
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    I am using a self-cert and all I did was point it to https://zimbraserver and accept the cert.

  3. #3
    Join Date
    Aug 2008
    Location
    St Pete FL USA
    Posts
    392
    Rep Power
    7

    Default

    I was hoping that would turn out to be a workable approach; thanks for confirming it, sir.
    Jay R. Ashworth - ZCS 6.0.9CE/CentOS5 - St Pete FL US - Music - Blog - Photography - IANAL - IAAMA
    Try to Ask Questions The Smart Way -- you'll get better answers.

    Put your product and version in your profile/signature - All opinions strictly my own, even though I have an employer these days.
    If you [SOLVE] something, please tell everyone how for the archives
    And, please... read what people write, and answer the questions they asked, not the ones they didn't.

  4. #4
    Join Date
    Aug 2008
    Location
    St Pete FL USA
    Posts
    392
    Rep Power
    7

    Default

    <s>Except for the part where Zimbra doesn't seem to be *listening* on 443, and I can't find a knob to turn that on...</s>

    Ok, discovered zmtlsctl and set it to both, discovered that it's mailboxd you have to bounce after that and did; now I can get to zmail on port 443 from my Sprint EV-DO connection.

    But the iPhone still tells me there's no server there. Any further suggestions from anyone? Could this be negative DNS caching on AT&T's network? I did have the zone wrong to start, and have since fixed that; I was told somewhere that lookupd caches this, and power cycling the phone clears it, but I suppose the network could be screwing me too, and I don't know what IP address to dig to check...
    Last edited by Baylink; 03-29-2010 at 12:22 PM.
    Jay R. Ashworth - ZCS 6.0.9CE/CentOS5 - St Pete FL US - Music - Blog - Photography - IANAL - IAAMA
    Try to Ask Questions The Smart Way -- you'll get better answers.

    Put your product and version in your profile/signature - All opinions strictly my own, even though I have an employer these days.
    If you [SOLVE] something, please tell everyone how for the archives
    And, please... read what people write, and answer the questions they asked, not the ones they didn't.

  5. #5
    Join Date
    Aug 2008
    Location
    St Pete FL USA
    Posts
    392
    Rep Power
    7

    Default

    No, it was something else; new thread going up for that, since it's a different problem.
    Jay R. Ashworth - ZCS 6.0.9CE/CentOS5 - St Pete FL US - Music - Blog - Photography - IANAL - IAAMA
    Try to Ask Questions The Smart Way -- you'll get better answers.

    Put your product and version in your profile/signature - All opinions strictly my own, even though I have an employer these days.
    If you [SOLVE] something, please tell everyone how for the archives
    And, please... read what people write, and answer the questions they asked, not the ones they didn't.

Similar Threads

  1. Replies: 2
    Last Post: 03-15-2010, 04:04 PM
  2. ZCS NE self signed certs: ca cert invalid for windows?
    By k3rmit in forum Administrators
    Replies: 5
    Last Post: 01-16-2010, 11:43 PM
  3. Upgrade Self Signed Cert to Commercial Cert (godaddy)
    By lareck in forum Administrators
    Replies: 1
    Last Post: 01-04-2010, 01:51 AM
  4. [SOLVED] 5.0.6 FOSS Instaling new Self Signed Cert Error
    By r8escjohn in forum Administrators
    Replies: 4
    Last Post: 02-26-2009, 07:17 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •