Results 1 to 5 of 5

Thread: Port forwarding SSL and Zimbra Mobile not working

  1. #1
    Join Date
    Feb 2011
    Posts
    8
    Rep Power
    0

    Default Port forwarding SSL and Zimbra Mobile not working

    First and foremost, I apologize if this is a duplicate. I couldn't find anything similar when I searched. Anyway, on with the show:

    I only have one public IP address. On the server it is assigned to, I run Zimbra Network Edition. I also have Apache running without SSL. I'd like to enable SSL so that I may run SVN through it. I found a guide on how to reconfigure Zimbra to a different SSL port and then reconfigure Apache to redirect traffic for the mail server to that port.

    When that was all said and done, Zimbra worked perfectly through a web browser. It would not work via an Exhange setup on an iPhone or an Android device. It indicated that it could not connect to the server.

    Looking at my zimbra logs, the connect never seems to actually make it to the Zimbra server. Nothing in the Apache logs indicate an error. The phone does not provide any valuable logging information.

    Here is my Apache config:

    <VirtualHost *:80>
    ServerName svn.myserver.com
    DocumentRoot /var/www/test
    </VirtualHost>
    <VirtualHost *:443>
    ServerName svn.myserver.com
    DocumentRoot /var/www/ssl
    SSLEngine on
    SSLOptions +StrictRequire
    SSLCertificateFile /etc/apache2/ssl/apache.pem
    </VirtualHost>
    <VirtualHost *:443>
    ServerName mail.myserver.com
    SSLEngine on
    SSLProtocol all -SSLv2
    SSLCipherSuite ALL:!ADH:!EXPORT:!SSLv2:RC4+RSA:+HIGH:+MEDIUM:+LOW
    SSLCertificateFile /opt/zimbra/ssl/zimbra/server/server.crt
    SSLCertificateKeyFile /opt/zimbra/ssl/zimbra/server/server.key
    Redirect / https://mail.myserver.com:60443/
    </VirtualHost>


    I'm completely stumped by this. Does anyone have any ideas? Thank you for taking the time to help me out.

  2. #2
    Join Date
    Feb 2011
    Posts
    8
    Rep Power
    0

    Default

    Sorry to bump this, I am trying to be patient for the right person to come across this. Any ideas?

  3. #3
    Join Date
    Dec 2010
    Posts
    3
    Rep Power
    4

    Default

    Did you set the server address as 'mail.myserver.com:60443' on your Android device? It works on my HTC Wildfire S.

  4. #4
    Join Date
    Feb 2011
    Posts
    8
    Rep Power
    0

    Default

    I did not. I was hoping that the android device would be able to just follow the port forward, just as the web browser does. I didn't want to force everyone to change the settings on their mobile device, so I just run HTTPS on a different IP address now.

  5. #5
    Join Date
    Dec 2010
    Posts
    3
    Rep Power
    4

    Default

    Yep, it's easier to run Zimbra on a separate IP.

    In fact, I tried both Redirect and Proxy from Apache to 60443 port, no success. At present we have to specify the port number on Android devices.

Similar Threads

  1. Did I miss something? (Zimbra GA 6.0.8 on Ubuntu 10.04)
    By vpetersson in forum Installation
    Replies: 2
    Last Post: 10-26-2010, 07:29 AM
  2. zmperditionctl start asking for password
    By k7sle in forum Administrators
    Replies: 32
    Last Post: 02-20-2008, 11:13 AM
  3. Major Issue - 5.0RC2 NE to 5.0GA NE failed
    By DougWare in forum Installation
    Replies: 7
    Last Post: 01-06-2008, 09:56 PM
  4. Cleanup after many upgrades
    By tobru in forum Installation
    Replies: 1
    Last Post: 12-23-2007, 09:21 AM
  5. Replies: 31
    Last Post: 12-15-2007, 09:05 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •