Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: ActiveSync Issues

  1. #1
    Join Date
    Apr 2007
    Posts
    37
    Rep Power
    8

    Default ActiveSync Issues

    I have been running into an error on a palm 700p. I get this message:

    AirSAMStateMachine.c 2885 1510 Possible Continuous Syn Server Error:
    see Microsoft Hotfix 923282

    It then wants me to do a full sync which takes longer. Any ideas?

    Also, another 700p ActiveSync issue for another user is that when we create appointments in the web interface, they always come up 6 hours late on the Treo. I know there are some bugs with Blackberrys like that, anything similar here?

  2. #2
    Join Date
    Jan 2007
    Posts
    1,688
    Rep Power
    11

    Default

    Does the error message you see on the phone actually refers to a Microsoft hotfix?

    Also for the 6 hour difference, are you saying that a meeting at 10am will show up as a meeting at 4pm on the phone?

  3. #3
    Join Date
    Apr 2007
    Posts
    37
    Rep Power
    8

    Default

    Yes, it does refer to a hotfix.

    And for the time difference, here are some tests I've done.

    1. Created all-day event on web interface.

    2. Manually set tz to EDT as usual. Synced cal via activesync. Appointment
    started 6 hrs late at 6am EDT and showed timestamp of 3am PDT.

    Repeated 1.

    3. Manually set tz to Honolulu time to compensate for the six hours. Synced
    cal via activesync. Appointment started now 6 hours early at 6pm EDT and
    showed a 9pm PDT start time. Weird.

    Repeated 1.

    4. Manually set tz to Los Angeles. Synced cal via activesync. Appointment
    shows up properly as an all-day event. Changed tz to New York. Appointment
    still shows up properly as an all-day event.

  4. #4
    Join Date
    Jan 2007
    Posts
    1,688
    Rep Power
    11

    Default

    For the first issue, best if you could open a support ticket so that we can see the sync.log file. That is if you still have the section from sync.log detailing what kind of transactions were going on leading eventually to the error. If possible we'd like to see at least a few hours' worth of sync.log right before the error.

    For the second issue, please be more specific on timezone settings. For example, what's the timezone of the web client computer. What's the system timezone of the phone. When you say "manually set", where and how did you do that? Thanks!

  5. #5
    Join Date
    Apr 2007
    Posts
    9
    Rep Power
    8

    Default

    We've been having horrible problems with AirSamStateMachine.c errors as well. If you find a solution, I hope you'll share it with the rest of us. The notes below are from an earlier post I made about the issue.

    ---------

    Several observations and common threads related to the problem:

    • It's triggered by having a lot of items to sync. It only seems to happen to users who have a lot of items to sync (e.g., users with few contacts or appointments don't have the problem, users with a lot do). Syncing longer time periods in the calendar also exacerbates the issue.
    • Users with the problem all imported their contacts via CSV files. Users who started from scratch in Zimbra don't seem to have the issue. This may be a conincidence, however, since none of our users who started fresh in Zimbra have enough contacts yet to trigger the issue. (And, if it doesn't get fixed soon, none ever will because we'll have to abandon Zimbra.)
    • It's not a network issue. Users on multiple carriers are affected and the problem also crops up when syncing using a direct cable connection.
    • It's not an issue with a specific Treo model. It's affecting Treo 650, 680 and 700p users.
    • Status bar is screwed up. There seems to be something wrong with how Zimbra and VersaMail figure out what records are "stale" and need to be updated. In particular, when syncs aren't working, the status bar showing sync progress is the wrong length.
    • It may be related to a drag-and-drop bug. A possibly related bug in Zimbra is that when a RANGE of contacts is dragged & dropped from a globally-shared contact folder to the user's contacts using shift-click in the browser, on the next sync they are not all sync'ed properly. If the records are selected individually (control click on each) they do seem to sync properly.
    • It's not an obvious Zimbra configuration issue. Tests with a Zimbra server on an oursourcing company showed the same problem.
    • It doesn't seem to be a problem with record data. Although it's hard to know for sure, it doesn't appear to be triggered by malformed data in records -- just the total quantity of records.


    It's not clear whether the issue is a Zimbra-VersaMail interaction or just a Zimbra issue. Either way, it's a horrible mess for the users and my company is on the verge of abandoning our Zimbra trial because if it.

    A warning to anyone evaluating Zimbra: This issue ONLY appears when a large number of items are being synced. You won't see if if you have just a few hundred appointments or a contacts. Basically, everything will work beautifully during your testing, then it'll clobber your power users and executives.[/QUOTE]

  6. #6
    Join Date
    Jan 2007
    Posts
    1,688
    Rep Power
    11

    Default

    Hi textpxy, I've seen your same post before. My advice to you at the time was to file a support ticket if you have a specific issue. Best way to resolve the problem is to provide detailed steps so that we can reproduce it.

    BTW, VersaMail client always shows AirSAMStateMachine.c error whenever something goes wrong. It is as generic as saying "it didn't work". Therefore it's highly unlikely that your AirSAMStateMachine.c issue is the same as someone else's AirSAMStateMachine.c issue

    Thanks!

  7. #7
    Join Date
    Apr 2007
    Posts
    37
    Rep Power
    8

    Default

    Where would I find the sync.log file?

    Also, for the Time zone issue, everything is set Eastern. It appears correctly in the web interface and iCal, but is not correct on my Treo

  8. #8
    Join Date
    Jan 2007
    Posts
    1,688
    Rep Power
    11

    Default

    sync.log is located under /opt/zimbra/log. It's rotated daily by default. You'll need to find the one that corresponds to the time period right before the issue, if the old log is not deleted.

    By "everything is EDT", do you mean that both your PC and your mobile device system are set to EDT?

    Thanks!

  9. #9
    Join Date
    Apr 2007
    Posts
    37
    Rep Power
    8

    Default

    That is correct, the only thing I am unsure of is if in the Zimbra web interface if that is set EDT, where can I go to look?

  10. #10
    Join Date
    Jan 2007
    Posts
    1,688
    Rep Power
    11

    Default

    Usually the timezone is picked up from your system timezone. However to be sure you can double check this way.

    1. Go to the "Options" tab and select "Calendar" sub tab. Make sure the checkbox "Show timezone list in appointment view" is checked.

    2. Open the appointment in question, and verify that the timezone selected is the one you want. Note that you'll have to be the organizer of the meeting in order to see the timezone selection in the appointment view.

Similar Threads

  1. Couple of Issues with Web Client
    By soxfan in forum Users
    Replies: 9
    Last Post: 09-13-2008, 01:58 PM
  2. Exchange 2003 Migration Issues
    By JordanPWilliams in forum Migration
    Replies: 10
    Last Post: 07-27-2007, 10:51 AM
  3. activesync to xv6700 calendar issues
    By phingers in forum Zimbra Mobile
    Replies: 4
    Last Post: 07-16-2007, 06:45 PM
  4. Sync with Palm Treo 700w with ActiveSync
    By jonnyRo in forum Zimbra Mobile
    Replies: 5
    Last Post: 01-05-2007, 03:39 PM
  5. ActiveSync Scheduling Error
    By bted in forum Zimbra Mobile
    Replies: 3
    Last Post: 11-09-2006, 08:00 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •