Results 1 to 2 of 2

Thread: Successful upgrade from 5.0.19 to 6.0.3

  1. #1
    Join Date
    Feb 2008
    Location
    Vancouver, BC Canada
    Posts
    28
    Rep Power
    7

    Thumbs up Successful upgrade from 5.0.19 to 6.0.3

    After not understanding the reason why I couldn't perform the upgrade immediately to 6 from my version of 5 (getting slapadd failed errors) I thought I would try again on 6.0.3.

    So trying 6.0.3 it also failed with the slapadd import failed and decided this time I better check logs and discovered in /tmp/zmsetup.log

    Code:
    Thu Nov 26 10:38:09 2009 *** Running as zimbra user: /opt/zimbra/openldap/sbin/slapadd -q -b '' -F /opt/zimbra/data/ldap/config -l /opt/zimbra/data/ldap/ldap.60
    <= str2entry: str2ad(ZIMBRADOMAINPREFMAILSIGNATURE): attribute type undefined
    slapadd: could not parse entry (line=1142)
    Thu Nov 26 10:38:09 2009 slapadd import failed.
    Doing a search on "ZIMBRADOMAINPREFMAILSIGNATURE" I discovered that this was part of the domain disclaimer extension I had installed and uninstalled donkeys ago as it really wasn't what we wanted and upgrading to different versions with it installed got messy. However this attribute had obviously remained in my LDAP db somehow even though it was not in my schema.

    So following this link on exporting/importing my LDAP data Exporting and Importing Zimbra LDAP Data » Zimbra :: Blog I removed these attributes from the dump

    Code:
    ZIMBRADOMAINPREFMAILSIGNATURE:: 
    ZIMBRADOMAINPREFMAILSIGNATUREHTML:: 
    ZIMBRADOMAINPREFMAILSIGNATUREENABLED: FALSE
    Reimported my LDAP data and hey presto the upgrade went like a dream!!!

    Hopefully others who have installed the domain disclaimer, removed it and then attempted the upgrade forgetting it makes changes to your schema will benefit from my post

  2. #2
    Join Date
    Oct 2008
    Location
    Portugal, Castelo Branco
    Posts
    63
    Rep Power
    7

    Default

    Thank you so much !

    I'm trying to update my zimbra server from 5.0.8 to the latest version, and i was unable to do so because of that.

    Removing those lines was perfect !

    Thank you so much !

Similar Threads

  1. Two Issues After Upgrade to 6.0.3
    By phether in forum Installation
    Replies: 17
    Last Post: 01-05-2010, 10:19 PM
  2. Upgrade from NE 5.0.19 to NE 6.0.2 Mac OSX
    By skenkin in forum Administrators
    Replies: 2
    Last Post: 11-18-2009, 04:39 AM
  3. Replies: 4
    Last Post: 03-31-2008, 03:52 PM
  4. Successful upgrade from OpenSuSE 10.0 (4.5.9 to 5.0)
    By bradb21 in forum Installation
    Replies: 6
    Last Post: 01-02-2008, 10:02 AM
  5. Successful Mac OS X upgrade of 4.05 -> 4.5?
    By mbd in forum Installation
    Replies: 3
    Last Post: 02-14-2007, 08:51 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •