Results 1 to 10 of 12

Thread: Smooth install of Zimbra in Ubuntu 6.10 (Edgy Eft)

Hybrid View

  1. #1
    Join Date
    Nov 2006
    Hilversum, The Netherlands
    Rep Power

    Thumbs up Smooth install of Zimbra in Ubuntu 6.10 (Edgy Eft)

    Just to give another heads-up feedback, I wanted to let you know I installed Zimbra 4.04 (OpenSource version) rather easy on Ubuntu 6.10 yesterday.

    I did encounter the LDAP error, mentioned several times in this forum, and I got that solved by the hints given in the wiki pages:
    LDAP startup ... FAILED (256) on UBUNTU, I solved my problems with 2 changes:

    1 UBUNTU by default symlinks /bin/sh to /bin/dash which does not support the 'source' command.

    To fix
    rm /bin/sh
    ln -s bash /bin/sh

    2 UBUNTU Server distro does not have a Java runtime, the certification startup

    The zimbra installer requires the java runtime in the /jre directory.
    Zimbra has a JRE available so simply a second symlink will solve the problem
    To fix:
    ln -s /opt/zimbra/jdk1.5.0_08/jre /jre

    The other two issues I had were
    1. manually stopping and starting the Zimbra suite showed an error during the startup of the spell module. It appeared the expat1 library was not installed. Using apt-get to install that piece of standard software fixed this. Should have been mentioned in one of the install guides though.
    2. Like others on this forum, I failed to see the statistics images. Again, some modules were missing, namely DBI and DBD::MySQL. apt-get these libraries, and now I also see the graphics.

    FYI, I installed Zimbra on a VERY lightweight server, a Pentium 1,6Gh with only 256M memory and a 80Gb ATA harddisk. Not for production, but just for test and I'm surprised by the fact that I don't have much swapping going on. The whole suite seems to fit in this tiny setup and the performance (single user, I admit) is very acceptable.

    So far, I have only one suggestion to enhance this product to be the Exch... killer: make the calendar function work with email clients like Evolution with CalDav or similar. Having a web based full client is great, integration with other clients would be superb. I've seen it's on the roadmap, and I already gave my vote to this feature request, but really guys, this would really rock Zimbra. Anyhow, I hope I'll be able to do some projects with Zimbra in the near future.

    Warm regards, Martin

  2. #2
    Join Date
    Aug 2006
    Rep Power


    Good job.
    I am still patiently waiting for apt-get install zimbra.
    “Paranoia is nothing more than a heightened sense of what's really going on around you!”

  3. #3
    Join Date
    Nov 2006
    Melbourne, Australia
    Rep Power


    I too, am eagerly awaiting for apt-get install zimbra, mainly because of the fact that zimbra will be updated using apt-get update/upgrade.
    Still, I am going to switch to it as soon as the Ubuntu version comes out of beta, because I desperately need to get away from our currently lacking mailserver.

  4. #4
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Vannes, France
    Rep Power


    Quote Originally Posted by rdjurovich View Post
    Still, I am going to switch to it as soon as the Ubuntu version comes out of beta, because I desperately need to get away from our currently lacking mailserver.
    just to let you know the Ubuntu version has now gone GA, you can download it from sourceforge.


    Acompli: A new adventure for Co-Founder KevinH.

  5. #5
    Join Date
    Nov 2006
    Melbourne, Australia
    Rep Power


    Thanks bill - I have been using Zimbra OS since the GA and have been enjoying every moment of it.

  6. #6
    Join Date
    Apr 2007
    Rep Power


    I had the same problem using Ubuntu 6.06. I followed the above directions but still got the problem. I was able to resolve the problem. I think the answer was to have ldap bind to the local port by changing some of the DNS settings. Here are the settings I used.

    I changed my hostname from --> mail


    I then changed my hosts file mail.localdomain -->

    /etc/hosts localhost mail mail

    I installed bind9 and configured DNS for internal lookups only.
    bind host file
    $TTL 604800
    @ IN SOA ns1.example. (
    604800 )

    @ IN NS ns1
    IN MX 10 mail
    mail IN MX 10 mail A
    IN A
    ns1 IN A
    mail IN A
    www IN A

    The I edited rc.conf to only use BIND for address look ups
    search home
    lookup bind

Similar Threads

  1. Replies: 26
    Last Post: 04-19-2011, 10:24 AM
  2. QUE Failure
    By tbullock in forum Administrators
    Replies: 31
    Last Post: 07-30-2008, 01:17 PM
  3. Zimbra Install Problem - getDirectContext
    By bsimzer in forum Installation
    Replies: 27
    Last Post: 07-19-2007, 11:12 AM
  4. Post instsallation problems
    By Assaf in forum Installation
    Replies: 14
    Last Post: 01-29-2007, 11:38 AM
  5. svn version still won't start
    By kinaole in forum Developers
    Replies: 0
    Last Post: 10-04-2006, 07:47 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts