I'm a long time Zimbra user, having used Zimbra for my small company (just me) and my family's (3) email since 2005.

I've just completed a migration from my ZCS 7.2.0 32 running on Ubuntu 8.04 32b to ZCS 7.2.4 64b running on Ubuntu 10.04 64b.

My final goal was to get to ZCS 8.0.4 64b on Ubuntu 12.04 64b....but after 2 days and countless hacks.....this has failed.

The actual install (install.sh) script never failed to run on any of the intermediate Virtual Machines I had set up in order to facilitate the migration from a 32 bit platform to the final 64 bit platform.

The plan was simple..and as follows...

backup ZCS 7.2.0 32 ubuntu 32b bit to my linux workstation as ../z720u8/
install/create ubuntu 8 32b vm (u832vm)
migrate zcs 7.2.0 to zcs 7.2.4 32b on u832vm.
install/create ubuntu 8 64b vm (u864vm).
migrate zcs7.2.4.32b to zcs7.2.4.64b on u864vm...this was the most difficult part....but worked very nicely..found guide in zimbra wiki.
install/create ubuntu 12.04 64b vm (u1264vm).
migrate zcs7.2.4 64b to u1264vm.....which worked very well in the vm.....the vm only.

NOTE: each vm was configured with a 40gb hard disk and only 1 (one) gb of ram.

since the migration appeared to work in the vm's...(VirtualBox)...I then installed ubuntu 12.04 64b server on the actual hardware computer...that only had 1gb of ram.....and then attempted to migrate the zcs installation from the u1264vm to the physical machine. This did not work....and I was very surprised. The install script ran correctly up to the point that it started the zcs services...and then tried to install the zimlets......and the whole process came to a screeching halt......did not actually stop...but the system's kernel ran out of memory and swap file space.....and nothing I did could correct it. I tried the swappiness sysctl setting of 0...this did not work.

I then thought...oh..maybe I skipped migrating the files to ubuntu 10 64 b on zcs 7.2.4........so I did this on my vm machine....
install/create ubuntu 10.04 64b vm (u1064vm).
migrate zcs 7.2.4 from u864vm to u1064vm...which worked very well.
migrate zcs 7.2.4 from u1064vm to u1264vm which worked very well.....

But then the move from the u1264vm to the physical machine running ubuntu 12 64b ran into the same out-of-memory error. Damn. I either need a shit-load amount of ram.....but research into the forum I found links of people having the same problem with 8.0.4 on machines with loads of ram..5 and 6 and 12 gb machines...all having the same out of memory errors.....some right away...others reporting that it would happen withing 48 hours....hmm...

...my conclusion...those that had a successfull migration to 8.0.4....might not have gone directly to 8.0.4.....but to one of the earlier 8.0.x releases....damn....and that is what I saw a lot of....in the forums.

so..my final solution...not optimal...was to migrate the installation from the u1064b vm (ZCS 7.2.4 64b) to my physical machine now running ubuntu 10.04 64b lts linux...and be happy with this for now.

When I have a machine with lots more ram than 1gb I will try the migration from ubuntu 10 64b up to ubuntu 12 64b with zcs 8.0.4 64b.....or maybe I will try to migrate to zcs 8.0.4 64b on the physical ubuntu 10 64b box.......but after 2 days.....I need a break.....and I might look at other email solutions that might be better suited to an installation of my size....4 mailboxes...lol...