Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: how to define icon for zimlet

  1. #1
    Join Date
    Feb 2008
    Posts
    11
    Rep Power
    7

    Default how to define icon for zimlet

    Hi all!

    My zimlet is not showing icon

    How to define icon for zimlet correctly?

  2. #2
    Join Date
    Feb 2006
    Posts
    92
    Rep Power
    9

    Default

    You have to declare the resource in the com_zimbra_zimletname.xml file:

    Code:
    <includeCSS>zimlet.css</includeCSS>
    <resource>zimleticon.png</resource>
    and the add the definition in the zimlet.css

    Code:
    .ImgZIMLETNAME-panelIcon {
     background: url("zimleticon.png") no-repeat 0 0;
     width: 18px;
     height: 18px;
     overflow: hidden;
    }
    Patricio Bruna
    http://www.itlinux.cl

  3. #3
    Join Date
    Feb 2008
    Posts
    11
    Rep Power
    7

    Question

    Still not working ((
    That thing makes me mad...


    Code:
    <zimlet name="com_zimbra_ppol" version="1.0" description="PPOL integration zimlet">
    
        <includeCSS>ppol.css</includeCSS>
        <resource>ppol.gif</resource>
    
        <userProperties>
            ...
        </userProperties>
    
        <zimletPanelItem label="PPOL" icon="PPOL-panelIcon">
            
            ....
    
        </zimletPanelItem>
    
    </zimlet>
    and here CSS:

    Code:
    .ImgPPOL-panelIcon {
      background: url("ppol.gif") no-repeat 0 0;
      width: 16px;
      height: 16px;
      overflow: hidden;
    }
    Please HELP!

  4. #4
    Join Date
    Feb 2006
    Posts
    92
    Rep Power
    9

    Default

    Had you restarted Tomcat or Jetty after made the changes?
    Had you deleted your browser cache and refresh the page?

    If still dont working, could you post or send me your zimlet to see if i can help?

    bye
    Patricio Bruna
    http://www.itlinux.cl

  5. #5
    Join Date
    Feb 2008
    Posts
    11
    Rep Power
    7

    Default

    Later today I will try to restart ZCS's webcontainer once customer will give me needed permissions

  6. #6
    Join Date
    Feb 2008
    Posts
    11
    Rep Power
    7

    Unhappy

    Today I restarted ZCS but did not see any changes: zimlet remains without specified icon, double-clicking on zimlet expands user properties window having old control which was removed from XML declaration.

    How do I clear caches?

    ZCS 5.0

  7. #7
    Join Date
    Feb 2008
    Posts
    11
    Rep Power
    7

    Default

    I had to create new zimlet with other name and move all contents to new one. Then it works fine.

    Seems like there is some ugly thing with zimlet data caches in zimbra

  8. #8
    Join Date
    Apr 2008
    Posts
    25
    Rep Power
    7

    Default Same problem

    I have exactly the same problem with the icons. I have done everything like it should and still it does not show up.

    When I use the _dev folder it suddenly shows the zimlet correctly.

    I also have a problem with the userproperties default editor which does not change if I deploy a new version of the zimlet (even after increasing the version number)

    any ideas?

  9. #9
    Join Date
    Apr 2008
    Posts
    25
    Rep Power
    7

    Default

    I have checked it a bit more and it appears to be a browser problem.
    I have the following setting:

    On the zimlet panel I have three zimlets:
    1. the standard Yahoo local zimlet
    2. I installed the SMS zimlet as an example and test
    3. My own zimlet

    The following happens in Firefox (v. 2 on windows and v3beta5 on Ubuntu):
    When I deploy my zimlet normally with the Zimbra admin as a zip, I do get an icon for 1 and 2 but not for 3
    When I deploy my zimlet in the _dev directory I get an icon for 1 and 3 but not for 2!!!

    When we check this with Internet Explorer on windows all icons show up correctly!
    I have tried to see what happens with the page info and the available resources, but this is a lost case with all the ajax code loading stuff.

    Does anybody know what is going on, does FF have problems with the style definitions for the icons??

  10. #10
    Join Date
    Apr 2007
    Location
    Paris, France
    Posts
    367
    Rep Power
    8

    Default

    I have the same problem with the property editor.
    Can we have please a confirmation from someone if there is a cache or something like this somewhere?

    For the icons, if you use icons already presents in zimbra :
    Forget the css file and the <ressource>, just put the name of the icon and it work. Exemple :
    Code:
    <zimlet name="com_zimbra_test" version="1.0" description="test zimlet">
        <zimletPanelItem label="Test" icon="Inbox">  
            ....
        </zimletPanelItem>
    </zimlet>
    This will give you a zimlet with icon of the Inbox folder.

Similar Threads

  1. Change Zimlet Icon??
    By kirme3 in forum Zimlets
    Replies: 3
    Last Post: 01-09-2008, 09:10 AM
  2. Replies: 7
    Last Post: 11-09-2007, 01:12 PM
  3. 4.04 Upgrade - Icon problems
    By dwill in forum Installation
    Replies: 10
    Last Post: 11-28-2006, 01:23 AM
  4. Zimbra Icon
    By bellzerr in forum Administrators
    Replies: 1
    Last Post: 09-22-2006, 04:37 PM
  5. DnD Icon vanishes if setVirtual() is invoked
    By MWaltman in forum Developers
    Replies: 2
    Last Post: 04-11-2006, 02:26 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •