Results 1 to 5 of 5

Thread: [SOLVED] Zimlet not showing up in ZWC zimlet list

Hybrid View

  1. #1
    Join Date
    Jan 2008
    Posts
    10
    Rep Power
    7

    Default [SOLVED] Zimlet not showing up in ZWC zimlet list

    I cannot get the URL zimlet to show up in the ZWC zimlet pane. Other zimlets do show up. Here is the deployment messages in mailbox.log:

    zimlet - Deploying Zimlet com_zimbra_url in LDAP.
    2008-02-23 20:27:37,605 WARN [Thread-5101] [] misc - checkValue: no attribute info for: zimbraZimletServerIndexRegex
    2008-02-23 20:27:37,609 INFO [Thread-5101] [] zimlet - Installing Zimlet com_zimbra_url on this host.
    2008-02-23 20:27:37,619 INFO [Thread-5101] [] zimlet - Installing Zimlet config for com_zimbra_url
    2008-02-23 20:27:37,621 INFO [Thread-5101] [] zimlet - Adding Zimlet com_zimbra_url to COS default
    2008-02-23 20:27:37,632 INFO [Thread-5101] [] zimlet - Enabling Zimlet com_zimbra_url

    Zimbra Admin client shows that it is Enabled in the default COS and in the Manage Zimlet tab but when logging in to the ZWC, it does not show up. Any help would be appreciated.

  2. #2
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

    Default

    Welcome to the forums,
    It doesn't have a button on the side zimlet pane.
    Send yourself an email and make the body:
    http:// zimbra.com
    Is that url blue/underlined/can you click it? - then it's working as designed
    There's other configuration you can do to preview url's.

  3. #3
    Join Date
    Jan 2008
    Posts
    10
    Rep Power
    7

    Default Preview URL

    Hi Mike,

    The URL does show up underlined and when I click on it, it opens a new window to that site. I am looking for the configuration to preview the URL, thanks for the clarification.

  4. #4
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

    Default

    If you want a preview of the webpages when you mouseover the url you have several options/methods of enabeling:
    su - zimbra
    cd /opt/zimbra/zimlets/

    1) zmzimletctl dumpConfigTemplate com_zimbra_url.zip
    nano config_template.xml
    edit:<property name="disablePreview">true</property>
    change it to false, and run
    zmzimlet configure config_template.xml

    2) cp com_zimbra_url.zip somewhere
    unzip com_zimbra_url.zip
    nano config_template.xml > edit edit "disablePreview" to false
    zip it back up and run
    zmzimletctl deploy com_zimbra_ul.zip
    (or 'install' instead of 'deploy')

    If you have a Alexa / Amazon thumbnail account you can also enter that account information as well.

    Go and mouse over a url, you should see a preview - if it's blank the first time it needs to generate the image - try again a little later.
    Also make sure it's enabled on your COS/User (deploying only enables on the default COS).
    If you want to force faster generation visit websnaper.com and use the address bar given to make it garb one on the spot (select small 202x152) then go back to zimbra and try it.
    If still nothing after lots of work, then try adding it to the allowed domains:<property name="allowedDomains">ast.amazonaws.com, *.websnapr.com</property>
    Last edited by mmorse; 02-24-2008 at 12:31 PM.

  5. #5
    Join Date
    Jan 2008
    Posts
    10
    Rep Power
    7

    Default

    I used option number 2 and it worked! :-) Thanks.

Similar Threads

  1. Replies: 21
    Last Post: 02-04-2010, 10:06 AM
  2. Outlook 2007 Beta error
    By bersrker in forum Zimbra Connector for Outlook
    Replies: 13
    Last Post: 07-17-2008, 08:38 AM
  3. Replies: 5
    Last Post: 01-11-2008, 05:34 AM
  4. Replies: 13
    Last Post: 07-20-2007, 04:21 AM
  5. Post instsallation problems
    By Assaf in forum Installation
    Replies: 14
    Last Post: 01-29-2007, 11:38 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •