Results 1 to 3 of 3

Thread: savealfresco zimlet problem

  1. #1
    Join Date
    Apr 2008
    Posts
    5
    Rep Power
    7

    Default savealfresco zimlet problem

    Hi all,

    I meet a problem when trying to store email into alfresco.
    When I dragged and dropped one conversation to "Save in Alfresco" icon. one error dialog was threw with a message: "Error in the properties' data, double click on the zimlet to modify the data"

    My data:
    alfresco server: https://xxx.xxx.xxx.xxx/alfresco
    username:
    password

    And I am sure that I can login alfresco server above with username and password

    (server using ssl)

    Please help me

    Thank you

  2. #2
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    25

    Default

    http://www.zimbra.com/forums/announc...r-profile.html please Have you upgraded Zimbra recently ?

  3. #3
    Join Date
    Apr 2007
    Location
    Paris, France
    Posts
    367
    Rep Power
    8

    Default

    For the alfresco server you must enter your ip address and eventually the port, not the whole url.
    Exemple : you use http://1.0.0.220:8080/alfresco. Then you enter "1.0.0.220:8080"
    But since I see that you use https, I'm affraid that it won't work. The zimlet is configured with http address.

    You can modify it by editing the zimlet. For that, do the following :
    -Unzip the com_starxpert_savealfresco.zip
    -Edit the file saveAlfresco.jsp
    -Change the line 809 :
    Code:
    WebServiceFactory.setEndpointAddress("http://" + servAl + "/alfresco/api");
    into :
    Code:
    WebServiceFactory.setEndpointAddress("https://" + servAl + "/alfresco/api");
    -Zip all the files in a new file com_starxpert_savealfresco.zip
    -Deploy this new zimlet.

Similar Threads

  1. Replies: 21
    Last Post: 02-04-2010, 10:06 AM
  2. Outlook 2007 Beta error
    By bersrker in forum Zimbra Connector for Outlook
    Replies: 13
    Last Post: 07-17-2008, 08:38 AM
  3. Replies: 5
    Last Post: 01-11-2008, 05:34 AM
  4. Domain Admin Error: Permission Denied
    By shanson in forum Administrators
    Replies: 3
    Last Post: 05-29-2007, 06:48 AM
  5. Post instsallation problems
    By Assaf in forum Installation
    Replies: 14
    Last Post: 01-29-2007, 11:38 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •