Results 1 to 2 of 2

Thread: [SOLVED] SOAP AuthRequest for SSO-style Authentication

Threaded View

  1. #1
    Join Date
    Jul 2007
    Location
    Buffalo, NY
    Posts
    7
    Rep Power
    8

    Default [SOLVED] SOAP AuthRequest for SSO-style Authentication

    I'm not one for asking for help but this one's got me stumped. I've searched through the forums and could not find a solution that helped with my particular problem. I'm trying to have my Zimlet call a web service (via /service/proxy) and the communication works fine but one thing I'm doing is passing the ZM_AUTH_TOKEN to my web service where I then proceed to send a SOAP call back to Zimbra to authenticate the user. Unfortunately, and I've tried many variations of this SOAP call, the call always fails with the same error message: service.AUTH_REQUIRED (no valid authtoken present)

    Here's a look at the SOAP I am both sending and receiving:

    Send:
    Code:
    <soap:Envelope xmlns:soap="http://www.w3.org/2003/05/soap-envelope">
         <soap:Header>
              <context xmlns="urn:zimbra" />
         </soap:Header>
         <soap:Body>
              <AuthRequest xmlns="urn:zimbraAccount">
                   <authToken>[ZM_AUTH_TOKEN]</authToken>
              </AuthRequest>
         </soap:Body>
    </soap:Envelope>
    Where the [ZM_AUTH_TOKEN] is *actually* the ZM_AUTH_TOKEN passed from the Zimlet in the service call (regex: /[0-9]_[a-z0-9]{40}_[a-z0-9]{200}/).

    Response from Zimbra:
    Code:
    HTTP/1.1 500 Internal Server Error
    Date: Wed, 06 Aug 2008 14:28:49 GMT
    Content-Type: text/xml; charset=utf-8
    Content-Length: 473
    
    <soap:Envelope xmlns:soap="http://www.w3.org/2003/05/soap-envelope">
         <soap:Header>
              <context xmlns="urn:zimbra"/>
         </soap:Header>
         <soap:Body>
              <soap:Fault>
                   <soap:Code>
                        <soap:Value>soap:Sender</soap:Value>
                   </soap:Code>
                   <soap:Reason>
                        <soap:Text>no valid authtoken present</soap:Text>
                   </soap:Reason>
                   <soap:Detail>
                        <Error xmlns="urn:zimbra">
                             <Code>service.AUTH_REQUIRED</Code>
                             <Trace>btpool0-2:1218032929477:c2fb88ceae4b666a</Trace>
                        </Error>
                   </soap:Detail>
              </soap:Fault>
         </soap:Body>
    </soap:Envelope>
    As far as I can tell, according to the limited documentation I've seen for SOAP & Zimbra this is perfectly fine, but it's obviously not working...
    Last edited by jonnybravo; 08-06-2008 at 10:40 AM.
    Jon

Similar Threads

  1. [SOLVED] Zimbra logwatch.
    By nishith in forum Administrators
    Replies: 5
    Last Post: 06-10-2009, 04:42 PM
  2. SOAP AuthRequest Question
    By ab5602 in forum Developers
    Replies: 3
    Last Post: 08-06-2008, 08:55 PM
  3. Replies: 3
    Last Post: 04-11-2008, 06:27 AM
  4. SOAP Authentication Failure, but LDAP ok
    By scottp in forum Administrators
    Replies: 2
    Last Post: 01-20-2008, 08:53 PM
  5. SOAP Authentication Error
    By eblanchette in forum Developers
    Replies: 2
    Last Post: 05-16-2007, 06:01 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •