Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: Yahoo! Translator Zimlet (beta)

  1. #1
    Join Date
    Aug 2008
    Posts
    4
    Rep Power
    7

    Default Yahoo! Translator Zimlet (beta)

    I just created a Zimlet for Yahoo!'s Babel Fish translation service, and I'm looking for testers.

    Please let me know if it works for you!

    Thanks,
    Aaron
    Attached Files Attached Files

  2. #2
    Join Date
    Apr 2007
    Location
    Paris, France
    Posts
    367
    Rep Power
    8

    Default

    Your first post so : Welcome to the forum !!!

    The zimlet works fine for me (I used french translation).

    1 bug but coming from babelfish site, not from your zimlet : there is ; added sometimes after " or '

    Also, it would be usefull that the zimlet select by default the translator :
    English to user language.

    To get the user locale :
    Code:
    settings.zimbraPrefLocale

  3. #3
    Join Date
    Aug 2008
    Posts
    4
    Rep Power
    7

    Default

    Good idea!

    This new version defaults to sensible languages based on the user's locale, and now has a preferences option to set the default languages to translate between.

    Again, let me know if it works for you!

    -Aaron
    Attached Files Attached Files

  4. #4
    Join Date
    Apr 2007
    Location
    Paris, France
    Posts
    367
    Rep Power
    8

    Default

    Last time i used the _dev folder but this time I deployed it.
    By deploying it we can detect a problem with the panelItem icon : it is not visible.

    Another problem : the selection button of the preferences doesn't work correctly : I can't click on the OK button because it open instead the list of the selection field. In fact, it open the selection field if you click anywhere under the selection field.

  5. #5
    Join Date
    Aug 2008
    Posts
    4
    Rep Power
    7

    Default

    I fixed the preferences dialog and have attached the new (and hopefully last! ) version to this post.

    Also, when I first deployed the Babel Fish zimlet on my install, it didn't show the icon, but I was able to fix it by running "zmprov flushCache account"

    -Aaron
    Attached Files Attached Files

  6. #6
    Join Date
    Apr 2007
    Location
    Paris, France
    Posts
    367
    Rep Power
    8

    Default

    zmprov flushCache account
    This didn't do the trick for me, I still doesn't see the icon.
    In the documentation :
    The Zimbra LDAP server caches the following types of entries
    • Skins
    ...
    • Zimlet configuration
    But the zmprov flushCache for the zimlet configuration is the only example missing...


    At first The property editor field was an Input text field, but it turned back to normal after restarting zimbra.


    It would also be better to replace the OK button by the translate button and change the cancel button in a "close" button, because this OK button is really confusing.

  7. #7
    Join Date
    Aug 2008
    Posts
    4
    Rep Power
    7

    Default

    I've added a button to insert the translation into a new mail message (I hope it's useful!), and replaced the "OK" and "Cancel" buttons with "Translate" and "Close"

    You should be able to flush the zimlet caches with "zmprov flushCache zimlet"

    -Aaron
    Attached Files Attached Files

  8. #8
    Join Date
    Apr 2007
    Location
    Paris, France
    Posts
    367
    Rep Power
    8

    Default

    I still can't see the icon , but besides that, everything works perfectly .

  9. #9
    Join Date
    Mar 2006
    Location
    Beaucaire, France
    Posts
    2,322
    Rep Power
    13

    Default

    Just tested on a 5.0.8 server and I'm getting "An error occurred when attempting to translate this message." (either if I type a sentence to be translated or if I drag'n'drop a message to the zimlet).

    Where should we dig to get some data about the error ?
    mailbox.log is empty (about this), so does zimbra.log

  10. #10
    Join Date
    Aug 2008
    Posts
    7
    Rep Power
    7

    Default Possible cause for the icon problem

    I also had a problem with the missing icon. Do you have in ZCS the Yahoo Local zimlet installed? Because this zimlet has a problem in the CSS file: after the last class definition it has a semicolon.

    When Zimbra mixes the CSS files for all the zimlets, this semicolon invalidates the next class that comes after, which might be the class for the Babel Fish translation zimlet. To test this, simply disable or undeploy the Yahoo Local zimlet.

    My solution for this was to add in my zimlet's CSS file a dummy class, right at the beginning of the file. This class is invalidated at runtime, and my real CSS class remains valid and processed by the browser.

    Tested with ZCS 5.0.8 and Firefox 3.

Similar Threads

  1. Is Zimbra a full offline Yahoo Mail client?
    By ivop in forum General Questions
    Replies: 4
    Last Post: 08-25-2008, 02:31 PM
  2. yahoo cant send email to zimbra account.. Why ???
    By bageur in forum Administrators
    Replies: 7
    Last Post: 05-08-2008, 05:50 AM
  3. Outlook 2007 Beta Overview
    By GregA in forum Zimbra Connector for Outlook
    Replies: 19
    Last Post: 03-03-2008, 04:24 PM
  4. Zimbra Apple iSync Beta
    By KevinH in forum CalDAV / CardDAV / iSync
    Replies: 47
    Last Post: 03-23-2006, 08:04 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •