Page 1 of 15 12311 ... LastLast
Results 1 to 10 of 149

Thread: Alfresco Zimlet (Beta)

  1. #1
    Join Date
    Aug 2008
    Posts
    16
    Rep Power
    7

    Default Alfresco Zimlet (Beta)

    Alfresco Zimlet provides integration between two leading open source solutions, Alfresco Enterprise Content Management and Zimbra Collaboration Suite. It was built on top of open technologies such as Alfresco Webscript, Zimbra Zimlet and YUI library.

    It allows the end user to save incoming email attachments to the Alfresco ECM Server. The user is provided with the ability to select multiple Alfresco documents and attach them to outgoing emails. Links are provided for downloading Alfresco Documents when composing emails from within Zimbra. Alfresco Documents and features are surfaced as shortcut links within the Zimbra application. Widgets are provided for ease-of-use in Alfresco space selection and repository navigation. A simple installation and setup is provided.

    Thanks!

    Yong Qu
    Attached Files Attached Files

  2. #2
    Join Date
    Sep 2005
    Posts
    76
    Rep Power
    10

    Default

    Tried it, but no luck, getting "Failed to Connect to Alfresco" all the time.
    Using Zimbra desktop and Alfresco 3.0b/2.1.

    Also, in org_alfresco_zimbra.js there is "for each" in line 453, resulting in error.

  3. #3
    Join Date
    Sep 2008
    Location
    United States
    Posts
    10
    Rep Power
    7

    Default

    A quicker way than creating aliases for all the users would be to create a domain alias, per the instructions at: http://wiki.zimbra.com/index.php?title=ManagingDomains

    Basically, have both domains on the Zimbra host. Batch rename all of the accounts as mentioned above so they exist in the new domain. Delete the old domain and create the domain alias. That way, existing users and new users alike automatically receive mail for both domains and it's a quick deletion later if you choose.

  4. #4
    yyovkov Guest

    Default saveAlfresco Spaces issue

    Hi,
    I am just playing with saveAlfresco. I am trying to create some subspaces to my existing space and to save emails with attachments there. But I could not see any subspaces.
    For example I could not see space: "/User Homes/myusername/MyMainSpace/MySubspace/MySubSubSpace".

    Thus make some restrictions in using the zimlet. Is there any way to make it more useful?

  5. #5
    yyovkov Guest

    Default

    I have played with saveAlfresco zimlet and found how to reproduce the issues I have mentioned above:
    1. When I create via Alfresco Web GUI new space with name in Bulgarian (UTF-8, non cyrillic), the space is not accessible via saveAlfresco zimlet
    2. When I mount alfresco space via cifs (mount.cifs) and I create space even with English name the name is not accessible via saveAlfresco zimlet.

    I hope the plugin is still in development so my tests are helpful for you!

  6. #6
    Join Date
    Aug 2008
    Posts
    16
    Rep Power
    7

    Default

    Hi, fselendic

    It has only been tested on Zimbra Collaboration Suite not the Zimbra Desktop.

    Yong

  7. #7
    Join Date
    Aug 2008
    Posts
    16
    Rep Power
    7

    Default

    Hi, yyokov

    Are you talking about the Alfresco Zimlet (beta) or the saveAlfresco zimlet that was developed by starxpert ?

    Yong

  8. #8
    yyovkov Guest

    Default

    I am sorry this was the wron place for the post.
    But I have also tried to install your plugin. Unfortunately it doesn't work on ZCS-5.0.10/CentOS-5.2 x86_64.
    If you have plans to debug it I can help you with tests.

  9. #9
    Join Date
    Aug 2008
    Posts
    16
    Rep Power
    7

    Default

    what error did you get? I have noticed that for installation, you might need to upload the zip file to Zimbra server. Unzip it and change all files/folders' owner to zimbra and then zip it again and make the owner as zimbra. then deploy it using command line.

    Yong

  10. #10
    yyovkov Guest

    Default

    Hi ygu,

    I have followed the steps you recommend, but I have no luck. I can find any error messages.
    When I press the right mouse button on the plugin, it displays the menu, but nothings happened when I select any of the three options, even the "Visit Alfresco" option.
    Please advise me where to get logs from and if you need someone to test your plugins I will do that for you.

    Regards,
    Yovko Yovkov

Similar Threads

  1. Replies: 21
    Last Post: 02-04-2010, 10:06 AM
  2. [SOLVED] Install Problem in Ubuntu 6.06 Server
    By xtimox in forum Installation
    Replies: 16
    Last Post: 03-27-2008, 10:36 AM
  3. Replies: 5
    Last Post: 01-11-2008, 05:34 AM
  4. Domain Admin Error: Permission Denied
    By shanson in forum Administrators
    Replies: 3
    Last Post: 05-29-2007, 06:48 AM
  5. Post instsallation problems
    By Assaf in forum Installation
    Replies: 14
    Last Post: 01-29-2007, 11:38 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •