Results 1 to 7 of 7

Thread: Date Zimlet not matching German Dates

  1. #1
    Join Date
    Oct 2008
    Posts
    2
    Rep Power
    7

    Default Date Zimlet not matching German Dates

    Hi guys,

    I've started recently to play around with Zimbra and I'm really impressed by it. I'm integrating it for German speaking folks and so I changed the internationalization to German of course.

    Now I have a problem with the Date Zimlet which matches dates from email or inline dates to show if there are calendar entries for that date. For one the matcher is able to match the month "Oktober" but shows January as a result. Dates in Germany are delimited with a "." so "20. Januar 2008" is not matched as january 20th 2008.

    I attached some screenshots to see for yourself. Maybe you can point me in the right direction to fix this as this poses a slight problem. I'm using Zimbra 5.0.8 on Red Hat EL.

    BR
    Chris
    Attached Images Attached Images

  2. #2
    Join Date
    Mar 2006
    Location
    Beaucaire, France
    Posts
    2,322
    Rep Power
    13

    Default

    Welcome to the forum.

    The problem is that the date differs from one country to another, thus different regular expression are needed.

    Look here : http://www.zimbra.com/forums/adminis...revisited.html

  3. #3
    Join Date
    Jul 2006
    Location
    Stuttgart / Germany
    Posts
    223
    Rep Power
    9

    Default

    Quote Originally Posted by peterschen View Post
    Hi guys,

    Now I have a problem with the Date Zimlet which matches dates from email or inline dates to show if there are calendar entries for that date. For one the matcher is able to match the month "Oktober" but shows January as a result. Dates in Germany are delimited with a "." so "20. Januar 2008" is not matched as january 20th 2008.


    BR
    Chris
    Hi Chris,

    you could try my version of the date Zimlet, that matches on german dates:

    http://www.zimbra.com/forums/zimlets...te-zimlet.html

    Regards
    Thomas

  4. #4
    Join Date
    Feb 2009
    Location
    Vienna, Austria
    Posts
    86
    Rep Power
    6

    Default

    The german version of the date-zimlet is not working with 6.0.1
    Code:
                         <\***/>
    Reinhard             ( . . )
    -------------------ooO--U--Ooo----

  5. #5
    Join Date
    Jul 2006
    Location
    Stuttgart / Germany
    Posts
    223
    Rep Power
    9

    Default

    Quote Originally Posted by reinhard View Post
    The german version of the date-zimlet is not working with 6.0.1
    Hi reinhard,

    it works for me (just tried in 6.0.1). Have you made sure, that the Zimlet is loaded an active?

    Regards
    Thomas

  6. #6
    Join Date
    Feb 2009
    Location
    Vienna, Austria
    Posts
    86
    Rep Power
    6

    Default

    Hi Thomas,

    strange - the zimlet is loaded and active.
    It worked fine with 5.0.18 but it doesn't with 6.0.1

    How can I check to have the latest version?
    I'll try to reinstall it.
    May be that would help.
    Code:
                         <\***/>
    Reinhard             ( . . )
    -------------------ooO--U--Ooo----

  7. #7
    Join Date
    Jul 2006
    Location
    Stuttgart / Germany
    Posts
    223
    Rep Power
    9

    Default

    Quote Originally Posted by reinhard View Post
    Hi Thomas,

    How can I check to have the latest version?
    I'll try to reinstall it.
    May be that would help.
    I only released one version - so you have the latest version :-)
    Make sure, the zimlet is active for your Cos/User. Reinstall/undeploy/deploy
    the zimlet could be helpful. Do you see the Zimlet in you user preferences in the "Zimlets" list ("Preferences" -> "Zimlets") and is it active?

    Regards
    Thomas

Similar Threads

  1. Replies: 21
    Last Post: 02-04-2010, 09:06 AM
  2. German version of date zimlet
    By deepblue in forum Zimlets
    Replies: 3
    Last Post: 12-14-2008, 02:34 AM
  3. Zimbra fails after working for 2 weeks
    By Linsys in forum Administrators
    Replies: 10
    Last Post: 10-07-2008, 12:42 AM
  4. Post instsallation problems
    By Assaf in forum Installation
    Replies: 14
    Last Post: 01-29-2007, 10:38 AM
  5. Date Zimlet speaks French
    By cvidal in forum I18N/L10N - Translations
    Replies: 4
    Last Post: 10-20-2006, 02:32 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •