Page 4 of 20 FirstFirst ... 2345614 ... LastLast
Results 31 to 40 of 198

Thread: Asterisk PBX Integration Zimlet (new)

  1. #31
    Join Date
    May 2008
    Posts
    15
    Rep Power
    7

    Default

    I was able to install the zimlet and get the configuration working and the zimlet looks brilliant! However, I can't get the calls to take place.

    I've confirmed from Asterisk that the manager account is logging in and logging out:

    Code:
      == Manager 'administrator' logged on from 192.168.111.124
      == Manager 'administrator' logged off from 192.168.111.124
    But the handoff doesn't take place and I'm not sure where to look. When I click the number in Zimbra it says "Pickup phone to dial number #######" and then two seconds later, "Failed to dial #######. Extension not found."

    Any suggestions on where to look? I've tried with multiple working phone extensions but it does not go. I've also verified that the manager "administrator" has the call and command attributes.

    Thanks!

  2. #32
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    25

    Default

    What does Asterisk show when this happens ?
    Code:
    asterisk -rvvvv

  3. #33
    Join Date
    May 2008
    Posts
    15
    Rep Power
    7

    Default

    Asterisk just shows the logon and logoff of the manager users. It's what I posted earlier:

    Code:
      == Manager 'administrator' logged on from 192.168.111.124
      == Manager 'administrator' logged off from 192.168.111.124
    It doesn't show any call attempts or failures.

  4. #34
    Join Date
    Aug 2008
    Posts
    72
    Rep Power
    7

    Default Dialplan?

    Hi bluecc
    The "Extension not found." means what it says. It seems that asterisk does not know the extension of the phone you want to place a call for. Are you sure the dialplan is right? Please check the extension you configured in the zimlets prefences dialog (srcPhone). Then recheck the zimlet global settings to match your dialplan. Especially the properties: astDialChannelType, srcPhonePrefix, astDialContext

    The source channel used to dial for is built the following way:
    Code:
    ${astDialChannelType}/${srcPhonePrefix}${srcPhone}
    Example:
    Code:
    <property name="astDialChannelType">SIP</property>
    <property name="srcPhonePrefix">77</property>
    <property name="astDialContext">internal</property>
    srcPhone Property in zimlet's user config: 10
    This means your voip phone you want to dial for needs to be configuerd in context internal and its channel is SIP/7710


    Hope this helps

  5. #35
    Join Date
    May 2008
    Posts
    15
    Rep Power
    7

    Default

    Thank you for the advice. It looks like I was handling the phone prefix and user preferences extension setting incorrectly. However, after changing I still have the same issue.

    As an overview, the extension I'm trying to use is 200. So I now have the following set:

    Code:
    <property name="astDialChannelType">SIP</property>
    <property name="srcPhonePrefix">2</property>
    <property name="astDialContext">phones</property>
    srcPhone Property in zimlet's user config: 00
    This is what is in the 'phones' context for that user:

    Code:
    exten => 200,1,Dial(SIP/200,20)
    exten => 200,n,VoiceMail(100,u)
    exten => 200,n,Playback(vm-goodbye)
    exten => 200,n,Hangup()
    This is what the dial plan for the phones context is:

    Code:
    exten => _X.,1,Set(CALLERID(ani)=OURNUMBERMASKED)
    exten => _X.,2,Dial(SIP/${EXTEN}@viatalk-2)
    exten => _XXXXXXXXXXX,1,Dial(SIP/viatalk-2/${EXTEN})
    exten => _011X.,1,Dial(SIP/${EXTEN}@viatalk-2)
    Any other thoughts on where to look or does something look out of place?

  6. #36
    Join Date
    Aug 2008
    Posts
    72
    Rep Power
    7

    Default

    Now you mixed up srcPhonePrefix
    With the settings you posted the phone's channel will be SIP/002 BTW: Four your setting its easier to let srcPhonePrefix empty. Then just set srcPhone Property in zimlet's user config to 200

  7. #37
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    25

    Default

    So srcPhonePrefix is essentially for if you need to dial a outside line eg. 9 ?

  8. #38
    Join Date
    Aug 2008
    Posts
    72
    Rep Power
    7

    Default srcPhonePrefix

    No the purpose of srcPhonePrefix is simply a string that is joined with zimelts users config (srcPhone). If you get a number block from your phone provider like 12 3400 - 12 3420 you can configure 1234 as srcPhonePrefix and the users need just to configure their extension that is used internally (means 00 - 20). E.g. user with extension 12 then configuers 12. The idea is that the extenal reachable direct number of that user will be 12 3412. But this depends on your dialplan.

    Hope this helps to clarify.

  9. #39
    Join Date
    May 2008
    Posts
    15
    Rep Power
    7

    Default

    I went ahead and left the srcPhonePrefix blank and just set the user preferences extension to 200. Unfortunately the problem still persists though.

    Any other thoughts on what to check? Does it matter how the extension is setup in sip.conf?

    Thanks for helping and I can't wait to get it working! Our users are really looking forward to this.

  10. #40
    Join Date
    Aug 2008
    Posts
    72
    Rep Power
    7

    Default sip.conf

    yes, sip.conf does matter... Whats the context you set there?

Similar Threads

  1. Replies: 21
    Last Post: 02-04-2010, 10:06 AM
  2. Outlook 2007 Beta error
    By bersrker in forum Zimbra Connector for Outlook
    Replies: 13
    Last Post: 07-17-2008, 08:38 AM
  3. Replies: 5
    Last Post: 01-11-2008, 05:34 AM
  4. weird Asterisk zimlet behaviour
    By bbarnett in forum Zimlets
    Replies: 4
    Last Post: 10-17-2007, 09:36 AM
  5. Post instsallation problems
    By Assaf in forum Installation
    Replies: 14
    Last Post: 01-29-2007, 11:38 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •