Page 7 of 20 FirstFirst ... 5678917 ... LastLast
Results 61 to 70 of 198

Thread: Asterisk PBX Integration Zimlet (new)

  1. #61
    Join Date
    Oct 2007
    Location
    Paris
    Posts
    15
    Rep Power
    8

    Default

    it work perfectly avec passing the astNoExtenCheck to false. Thanks a lot !!!

  2. #62
    Join Date
    Nov 2007
    Location
    Germany
    Posts
    17
    Rep Power
    8

    Default

    Hi,

    just installed and configured the zimlet and already did some debugging...

    our SIP channels are like: phone-manufacturer-#
    e.g: phone-linksys-2 is the channel name!

    everytime i dial the log is:

    zimlet - ch_bnc_asterisk caller: phonelinksys2 callee 203
    so phone-linksys-2 -> phonelinksys2
    does the SOAP "kill" the "-" ?

    any ideas? (changing the SIP name isn't a solution)

    Thanks Martin
    There is no good day since you make it one!

  3. #63
    Join Date
    May 2008
    Posts
    15
    Rep Power
    7

    Default

    Sorry for not updating in so long. But I have good news!

    Simply adding the hint lines to my phones context solved it!

    After adding that and reloading, I clicked and my desk phone rang right away. I picked it up and sure enough it went right out. Two way audio is working as well.

    So thank you so much!

    Quote Originally Posted by chlauber View Post
    Finally got the problem! Actually for the ExtensionState action you need hints. So starting with Zimlet version 0.6 I added a feature to check the ExtensionState before placing the call. Seems that this is an old issue. Sorry!
    [Asterisk-Dev] ExtensionState problems using Manager.conf API
    So the easiest way ist to add
    Code:
    exten => 200,hint,SIP/200
    To your phones context.

  4. #64
    Join Date
    Aug 2008
    Posts
    72
    Rep Power
    7

    Default

    Quote Originally Posted by mmbl13 View Post
    Hi,

    just installed and configured the zimlet and already did some debugging...

    our SIP channels are like: phone-manufacturer-#
    e.g: phone-linksys-2 is the channel name!

    everytime i dial the log is:
    zimlet - ch_bnc_asterisk caller: phonelinksys2 callee 203
    so phone-linksys-2 -> phonelinksys2

    does the SOAP "kill" the "-" ? any ideas? (changing the SIP name isn't a solution)

    Thanks Martin
    Hi Martin
    No SOAP does not kill the '-'. Actually I do some number checking in asterisk.jsp. In fact this is not necessary for the caller (which is taken from the zimlet user propery srcPhone). So you can try to remove line 496 in asterisk.jsp that contains this code:
    Code:
    			caller=checkNumber(caller);
    Then i would expect it to work. I think i will remove that that check in future versions, too ...
    Let me now if it worked

  5. #65
    Join Date
    Nov 2007
    Location
    Germany
    Posts
    17
    Rep Power
    8

    Default

    Hi,

    thanks that helped! works great now!
    good work... keep going

    Martin
    There is no good day since you make it one!

  6. #66
    Join Date
    Dec 2008
    Posts
    7
    Rep Power
    6

    Default

    Wow, that was intense. After 6 hours of head banging, I got it working. Problems turned out to be Asterisk 1.6 related.

    1) If you run Asterisk 1.6.x, you'll need to add 'originate' privs (new in 1.6) to your manager user:

    Code:
    read = system,call,log,verbose,command,agent,user,originate
    write = system,call,log,verbose,command,agent,user,originate
    ... otherwise the 'originate' command will get rejected with "Permission denied", although you won't see this in the mailmanager log, you'll just see a generic originate failure. I'm not sure if it needs originate on both read and write, I just put it on both to be sure.

    2) If you run 1.6.0.3, you'll need to patch your Asterisk as per this bug:

    0014208: Channel not specified - Asterisk-1.6.0.3 - Digium Issue Tracker

    ... (file you need is main/manager.c) then make, make install and restart Asterisk. Without this, the 'originate' command always gets rejected with "Channel not specified", even though it is specified.

    If you run FreePBX in vanilla form, you'll probably need to config with:

    Code:
        <property name="astDialContext">from-internal</property>
        <property name="astDialChannelType">Local</property>
    Whoo HOOOO! It works.

    Thanks chlauber, this is awesome.

    -- hugh

  7. #67
    Join Date
    Dec 2008
    Posts
    7
    Rep Power
    6

    Default

    Can we pretty please have a dial prefix config option? Similar to srcPhonePrefix, but for prefixing the callee with?

    -- hugh

  8. #68
    Join Date
    May 2008
    Posts
    15
    Rep Power
    7

    Default

    Probably a simple question but how do you adjust so it can dial different number formats?

    For example, right now it's just dialing 5555555 for me but I also need 555.555.5555 and 555-555-5555.

    Thanks!

  9. #69
    Join Date
    Dec 2008
    Posts
    7
    Rep Power
    6

    Default

    You need to fiddle with the matchingRegEx in your zimlet config. Which can be a little scary if you aren't familiar with regex pattern matching.

    Someone mentioned building a better, multi-purpose regex earlier in this thread, but I haven't seen any followup on that yet. I'm about to start rebuilding my matchingRegEx to recognize more formats, I'll post when I have something working.

    -- hugh

  10. #70
    Join Date
    Aug 2008
    Posts
    72
    Rep Power
    7

    Default Dial Prefix

    Quote Originally Posted by cheesegrits View Post
    Can we pretty please have a dial prefix config option? Similar to srcPhonePrefix, but for prefixing the callee with?

    -- hugh
    Hi hugh
    What would fits your needs best? A global config in zimlets config xml or a per user configurable option?

Similar Threads

  1. Replies: 21
    Last Post: 02-04-2010, 10:06 AM
  2. Outlook 2007 Beta error
    By bersrker in forum Zimbra Connector for Outlook
    Replies: 13
    Last Post: 07-17-2008, 08:38 AM
  3. Replies: 5
    Last Post: 01-11-2008, 05:34 AM
  4. weird Asterisk zimlet behaviour
    By bbarnett in forum Zimlets
    Replies: 4
    Last Post: 10-17-2007, 09:36 AM
  5. Post instsallation problems
    By Assaf in forum Installation
    Replies: 14
    Last Post: 01-29-2007, 11:38 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •