Results 1 to 10 of 10

Thread: which of the "extra" zimlets work?

  1. #1
    Join Date
    Aug 2007
    Posts
    220
    Rep Power
    8

    Default which of the "extra" zimlets work?

    I've been trying to deploy some of the zimlets in the extra directory under 5.0.10 and none of them seem to work. I followed the steps in the wiki and they simply don't show up, no matter how much I play with the cos, domain, and user zimlet settings.

    what am I doing wrong?

  2. #2
    Join Date
    Aug 2007
    Location
    Pune, India
    Posts
    46
    Rep Power
    8

    Default

    Have you restarted zmmailboxdctl?
    Do you see any errors in mailbox.log while deploying them?
    - Irfan




  3. #3
    Join Date
    Aug 2007
    Posts
    220
    Rep Power
    8

    Default

    Yup restarted everything, no errors in mailbox.log, all the config options say they should be there, and they are not. Mostly working with the gtranslator one, but a few others too. I'll beat on it some more on Monday. The only one that seems to work are the default ones, including _local

  4. #4
    Join Date
    May 2008
    Location
    Sierra Vista, Az
    Posts
    74
    Rep Power
    7

    Default

    Are you deploying them via the admin gui or the cli? I have been able to deploy the gtranslator fine everytime....but I do it through the cli.

  5. #5
    Join Date
    Aug 2007
    Posts
    220
    Rep Power
    8

    Default

    I'm using the CLI but clearly I'm doing something stupid.

  6. #6
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

    Default

    Appear for host/ldap/cos in zmzimletctl listZimlets?

  7. #7
    Join Date
    Nov 2006
    Location
    Bordeaux, France
    Posts
    140
    Rep Power
    8

    Default

    We also had a that kind of problem with a lot of zimlets and finally found the answer. (thanks to klug)

    zimlets connect to internet via an internal proxy included in zcs.

    You must setup this proxy to allow external domains to talk with zimlets. YOu must do this for each COS.

    Exemple for BabelFish zimlet : it needs to reach *.yahoo.com...

    let's see what's is already setup :
    zmprov gc <yourcosname> | grep zimbraProxyAllowedDomains

    To allow domain (here with 2 domains in the same command) :
    zmprov mc <yourcosname> zimbraProxyAllowedDomains *.yahoo.com zimbraProxyAllowedDomains *.zimbra.com

    let me know if it helps.

  8. #8
    Join Date
    Mar 2006
    Location
    Beaucaire, France
    Posts
    2,322
    Rep Power
    13

    Default

    Merci Philippe 8)

    Additionnaly, some of the zimlets are known to be broken (the Webbex one for example, several bugs in the bugzilla).

  9. #9
    Join Date
    Aug 2007
    Posts
    220
    Rep Power
    8

    Default

    I've put this one on the back burner for a while, because I had bigger problems to worry about.

    Now is back upfront. The problem Im seeing is a bit stranger then I realized. It seems SOME users see the zimlets and some don't. There is no real difference between the user settings, same domains, same COS, created at the same time, the same way. One user sees one widget, the other sees four.

    If anyone has any idea what I've done crazy, please let me know because I'm really confused now.

  10. #10
    Join Date
    May 2008
    Location
    France
    Posts
    16
    Rep Power
    7

    Default

    Quote Originally Posted by NOZIL View Post
    We also had a that kind of problem with a lot of zimlets and finally found the answer. (thanks to klug)

    zimlets connect to internet via an internal proxy included in zcs.

    You must setup this proxy to allow external domains to talk with zimlets. YOu must do this for each COS.

    Exemple for BabelFish zimlet : it needs to reach *.yahoo.com...

    let's see what's is already setup :
    zmprov gc <yourcosname> | grep zimbraProxyAllowedDomains

    To allow domain (here with 2 domains in the same command) :
    zmprov mc <yourcosname> zimbraProxyAllowedDomains *.yahoo.com zimbraProxyAllowedDomains *.zimbra.com

    let me know if it helps.
    That pointed me in the right direction, with a note: quoting the Zimbra Wiki

    To add a domain to the allowed domains list, from a command line, run the following:

    zmprov mc {cos-name} +zimbraProxyAllowedDomains {missing-domain-name}

    Where:

    * {cos-name} is the Class of Service
    * {missing-domain-name} is the omain name (such as *.google.com or *.myexternaldomain.com)

    Note: Be sure to incude the "+" symbol in-front of the "zimbraProxyAllowedDomains" COS name. The "+" symbol indicates to append the new domain domain to the existing domain list; otherwise, you will overwrite all domains. Alternatively, use "-" symbol in-front of the "zimbraProxyAllowedDomains" to remove a particular instance of an attribute.

Similar Threads

  1. Zimlets doesn't work !!
    By doctau in forum Zimlets
    Replies: 8
    Last Post: 10-11-2010, 04:18 AM
  2. Replies: 1
    Last Post: 04-07-2008, 08:58 AM
  3. Zimlets won't work
    By Petrus in forum Zimlets
    Replies: 4
    Last Post: 03-20-2008, 03:09 AM
  4. Zimlets and Dist. Lists Wont work
    By leog21 in forum Administrators
    Replies: 4
    Last Post: 11-14-2007, 01:32 PM
  5. where are my zimlets ?
    By santo in forum Zimlets
    Replies: 21
    Last Post: 06-05-2007, 07:30 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •