Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Zimlet - Send Contact Information Via Email

  1. #1
    Join Date
    Sep 2008
    Location
    Akron, New York
    Posts
    2
    Rep Power
    7

    Default Zimlet - Send Contact Information Via Email

    I would like to create a zimlet where you could drag a contact onto it. At this point it would open a new email, and paste the contact information into the body of the email.

    That way, if someone outside my company wants a contact I can at least give it to them easily.


    Is this possible?

  2. #2
    Join Date
    Apr 2007
    Location
    Paris, France
    Posts
    367
    Rep Power
    8

    Default

    Of course it is possible. And rather easy to do.
    Here is a zimlet sample that should help you :
    http://www.zimbra.com/forums/zimlets...ted-email.html

  3. #3
    Join Date
    Feb 2009
    Location
    Vienna, Austria
    Posts
    86
    Rep Power
    6

    Default

    Hi,

    if you could manage this and made a working zimlet, I would be interested in it.

    Can you post it to the zimlet gallery and let me know please?

    Thanks for your affort
    Code:
                         <\***/>
    Reinhard             ( . . )
    -------------------ooO--U--Ooo----

  4. #4
    Join Date
    Apr 2009
    Location
    Belgium
    Posts
    1
    Rep Power
    6

    Default mail contact zimlet

    I've made a Zimlet that enables you to drag a contact, type in subject and body and mail the message with the contact as VCF in attached.

    You can find it here:
    Get or contribute Zimlets, UI themes, and languages in the Zimbra Gallery - Contact Mailer

    Grts, Koen

  5. #5
    Join Date
    May 2008
    Posts
    432
    Rep Power
    7

    Default

    Hi, thanks for the Zimlet.

    It does not work for me, though...

    Nothing happens, I can not drag anything onto it (red, instead of green). It does not open anything when clicking.

    Any ideas?

  6. #6
    Join Date
    Feb 2007
    Posts
    8
    Rep Power
    8

    Default

    Quote Originally Posted by iway View Post
    Hi, thanks for the Zimlet.

    It does not work for me, though...

    Nothing happens, I can not drag anything onto it (red, instead of green). It does not open anything when clicking.

    Any ideas?
    I had this same issue. There's a borken zimlet that is stopping other zimlets from executing. Disable them one by one, until you find the broken zimlet. For me it was the rootly news.

    Once that broken one was disabled the other zimlets worked.

  7. #7
    Join Date
    Apr 2008
    Location
    France
    Posts
    48
    Rep Power
    7

    Default

    I think it would be more simple to begin from the attachmail Zimlet as it would be integrated in the "Add attachment" when composing a new mail.

    The new tab in the attachment popup would allow the user to browse within its contacts and select the one he wants to add.


    The problem I have with the "contact attachment" zimlet is that you normally attach a vcard in a mail that has already a discussion. Usually you say to someone after a discussion that you attach the contact in the next e-mail so you can keep

    However, with this zimlet, it's a complete new mail that is being created and you don't have the discussion.

    This zimlet is, in my opinion, a first step to attach a vcard to an e-mail and this is really great that someone tried to solve this missing part of Zimbra
    3 Release 5.0.16_GA_2313.UBUNTU6 Network edition
    AND
    1 Release 6.0.0_BETA2_1547.UBUNTU8 UBUNTU8 FOSS edition

  8. #8
    Join Date
    Feb 2007
    Posts
    8
    Rep Power
    8

    Default FOSS V. 6.01 breaks contact zimlet

    Upgraded to the new Zimbra and now the mailcontact zimlet is broken. This was a very useful zimlet as it allows people to keep the BB up to date with out the BEX extentions.

    Any word on if this will be updated, or if Zimbra plans to allow the emailing of vCard attachments, which I agree is the best solution, and most standardized.

    PS This seemed to be a feature in 4.5 - why is it not anymore????
    Last edited by MikelBGI; 10-13-2009 at 11:23 AM.

  9. #9
    Join Date
    Feb 2007
    Posts
    8
    Rep Power
    8

    Default

    Got it to work in 6.01

    Undeploy the zimlet, then re-deploy. Viola!

  10. #10
    Join Date
    Feb 2010
    Posts
    1
    Rep Power
    5

    Default dead link for the zimlet

    The link to download this zimlet is broken... anyone have the correct one?

Similar Threads

  1. Replies: 21
    Last Post: 02-04-2010, 09:06 AM
  2. 4.5.11 to 5.06 Migration Suggestion
    By newmember in forum Migration
    Replies: 15
    Last Post: 09-02-2008, 06:59 PM
  3. Outlook 2007 Beta error
    By bersrker in forum Zimbra Connector for Outlook
    Replies: 13
    Last Post: 07-17-2008, 07:38 AM
  4. [SOLVED] Install Problem in Ubuntu 6.06 Server
    By xtimox in forum Installation
    Replies: 16
    Last Post: 03-27-2008, 09:36 AM
  5. cannot send email to sina/yahoo
    By koolokamba in forum Administrators
    Replies: 2
    Last Post: 06-20-2006, 08:03 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •