Results 1 to 1 of 1

Thread: Inova Google Maps Zimlet - API Key not working

  1. #1
    Join Date
    Dec 2008
    Location
    San Rafael, CA
    Posts
    113
    Rep Power
    7

    Default Inova Google Maps Zimlet - API Key not working

    Hi!
    I am trying to get the Gmaps Zimlet to work in my Zimbra Collaborative Suite 5.0.16 on

    Code:
    [root@zimbra ~]# cat /proc/version
    [root@zimbra ~]Linux version 2.6.18-128.1.10.el5 (mockbuild@builder10.centos.org) (gcc version 4.1.2 20080704 (Red Hat 4.1.2-44)) #1 SMP Thu May 7 10:35:59 EDT 2009
    I followed the README in the ZIP file explicitly but I cannot get it working. Says it can't make out the API.

    Zimbra is installed on two servers connected with heartbeat. I have changed the IPs for security reasons.
    Each server has its own static IP address and then to a common IP. This is done for when one server goes down and the other comes up the IP to the router doesn't change.
    Currently (until the next server crash), the server that is currently live is 10.0.1.22. The server that is standby is 10.0.1.21
    The common IP is 10.0.1.25

    When I connect the config.xml file to the zimlet it says that it worked.

    Code:
    [root@zimbra ~]# zmzimletctl configure config.xml net_inova_gmaps
    [root@zimbra ~]tail ../log/mailbox.log
    [root@zimbra ~]2009-05-13 00:41:52,038 INFO  [btpool0-814] [ip=10.0.1.22;ua=Jakarta Commons-HttpClient/3.0;] mailbox - FileUploadServlet received Upload: { accountId=e0fafd89-1360-11d9-8661-000a95d98ef2, time=Wed May 13 00:41:52 PDT 2009, uploadId=0cd5dad5-e5eb-4d8c-aa05-f2ebd37aefe8:9707732a-ae51-4a15-a768-96426f681646, config.xml}
    2009-05-13 00:41:52,042 INFO  [btpool0-814] [name=zimbra;ip=10.0.1.22;] soap - ConfigureZimletRequest
    2009-05-13 00:41:52,045 INFO  [btpool0-814] [name=zimbra;ip=10.0.1.22;] zimlet - Installing Zimlet config for Net_Inova_GMaps
    I have the zimlet enabled all the way to the user and it shows up in their account as active from the Administration Panel.

    I then send an email to myself with an address in this format:

    1 Any St, Anytown, Anystate 12345

    The Gmaps zimlet is working as the address is hyperlinked live plus if I click on it the requester for manual lookup works as does dragging a contact over the zimlet.

    But, when I hover over the address the pop-up does appear but says that it can't find the API Key for the domain mail.marininstitute.org.

    The API Key was made for domain marininstitute.org.
    The server's domain is mail.marininstitute.org. According to Google this is correct and recommended.

    I am attaching the config.xml file with pertinent information changed as a TXT file.

    Please advise what is wrong and if you need any more information.
    Attached Files Attached Files
    Last edited by bmw; 05-13-2009 at 02:45 AM.

Similar Threads

  1. Replies: 21
    Last Post: 02-04-2010, 10:06 AM
  2. [SOLVED] Install Problem in Ubuntu 6.06 Server
    By xtimox in forum Installation
    Replies: 16
    Last Post: 03-27-2008, 10:36 AM
  3. Replies: 5
    Last Post: 01-11-2008, 05:34 AM
  4. Replies: 13
    Last Post: 07-20-2007, 04:21 AM
  5. Post instsallation problems
    By Assaf in forum Installation
    Replies: 14
    Last Post: 01-29-2007, 11:38 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •