Results 1 to 3 of 3

Thread: Zimlet no changes effects!

  1. #1
    Join Date
    Sep 2008
    Posts
    20
    Rep Power
    7

    Default Zimlet no changes effects!

    I've developed a zimlet using the zdesktop. Now I want to deploy it on my ZCS live server. After i deployed, i found that i got some mistake on my code.

    So I change some of it, re-zip it, re-deploy (undeploy n deploy) it.
    But I can't see the code is changing. It seems like the zimlet will not take effect until I restart the mailbox service.

    However, if i change the zimlet's name, it will takes effect. It will treat it as a new zimlet.

    Does anyone know what is the best way to 'refresh' the changes of my zimlet without restarting the mailbox service. Because my server is running in production, restarting it might takes few minutes and I can't afford that downtime.

    Thanks in advanced!

  2. #2
    Join Date
    Nov 2005
    Posts
    477
    Rep Power
    10

    Default

    Check the version number in the XML file. It must be incremented for the uopgrade to occur.

  3. #3
    Join Date
    Sep 2008
    Posts
    20
    Rep Power
    7

    Default

    erm.. I tried.
    Previous version is 1.0
    After i changed, i put 1.1, deployed n re-deployed, refresh browser, no effects.

    But I ssh into the server and check on:
    /opt/zimbra/jetty/webapps/service/zimlet/<my_zimlet_name>/<my_zimlet_name>.xml
    The version had been changed and also I check on my javascript (.js) code, the code did changed to the latest one.

    But I don't get the effect on my browser when I refresh. I putting an alert("Hello") in the event of "singleClicked".

    Anyway, thx for your reply.

Similar Threads

  1. Replies: 21
    Last Post: 02-04-2010, 10:06 AM
  2. Outlook 2007 Beta error
    By bersrker in forum Zimbra Connector for Outlook
    Replies: 13
    Last Post: 07-17-2008, 08:38 AM
  3. Replies: 5
    Last Post: 01-11-2008, 05:34 AM
  4. Replies: 13
    Last Post: 07-20-2007, 04:21 AM
  5. Post instsallation problems
    By Assaf in forum Installation
    Replies: 14
    Last Post: 01-29-2007, 11:38 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •