Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Can't Configure GMaps Zimlet

  1. #1
    Join Date
    Jul 2007
    Posts
    227
    Rep Power
    8

    Default Can't Configure GMaps Zimlet

    Using OSS 5.0.16 and have gotten the inova_gmaps zimlet in the zimbra/zimlets folder and ran the zmzimletctl deploy command and everything seems to be fine there. When running:
    zmzimletctl configure config.xml net_inova_gmaps
    [] INFO: Configure zimlet on mail.electrichendrix.com
    [] ERROR: Error
    com.zimbra.common.soap.SoapFaultException: system failure: cannot configure
    ExceptionId:btpool0-49:1246905792255:1f2e4020cf07c700
    Code:service.FAILURE
    at com.zimbra.common.soap.Soap12Protocol.soapFault(So ap12Protocol.java:88)
    at com.zimbra.common.soap.SoapTransport.extractBodyEl ement(SoapTransport.java:263)
    at com.zimbra.common.soap.SoapTransport.parseSoapResp onse(SoapTransport.java:224)
    at com.zimbra.common.soap.SoapHttpTransport.invoke(So apHttpTransport.java:277)
    at com.zimbra.common.soap.SoapHttpTransport.invoke(So apHttpTransport.java:226)
    at com.zimbra.common.soap.SoapTransport.invoke(SoapTr ansport.java:315)
    at com.zimbra.common.soap.SoapTransport.invoke(SoapTr ansport.java:279)
    at com.zimbra.cs.zimlet.ZimletUtil$ZimletSoapUtil.soa pConfigureZimlet(ZimletUtil.java:1341)
    at com.zimbra.cs.zimlet.ZimletUtil$ZimletSoapUtil.con figureZimletOnServer(ZimletUtil.java:1325)
    at com.zimbra.cs.zimlet.ZimletUtil$ZimletSoapUtil.con figureZimlet(ZimletUtil.java:1208)
    at com.zimbra.cs.zimlet.ZimletUtil.dispatch(ZimletUti l.java:1597)
    at com.zimbra.cs.zimlet.ZimletUtil.main(ZimletUtil.ja va:1641)

    I have followed the readme, i thought, exactly. I do get confused where the readme says to Create a file with the following lines and replace the values for dbhost, dbuser, dbpass, dbname and baseCountry (i understand the dbhost, dbuser, dbpass, dbname and baseCountry part) but it does not say what name to give this file? A little further down and the readme says to run zmzimletctl configure config.xml net_inova_gmaps so i assume the file name should be config.xml? I am also unsure where i need to be running this command from, i.e what directory (zimlets or does it matter?)? Like i said, i have the zimlet deployd and the admin interface sees the zimlet. I have the api key. I have created a DB for this map and have populated a table with said key. Can anyone help?

    I also wanted to mention that the mysql DB is a separate DB from the zimbra mysql DB and that DB has a password with special characters. Does it handle passwords with special characters?
    Last edited by carnold; 07-06-2009 at 12:51 PM.

  2. #2
    Join Date
    Oct 2008
    Posts
    5
    Rep Power
    7

    Default

    It should handle the spectial characters fine, as long as it is properly escaped in the xml file.

    You can try to use a xml editor so it escapes the characters for you, or you can change the password to a simpler one and test it.

  3. #3
    Join Date
    Jul 2007
    Posts
    227
    Rep Power
    8

    Default

    Quote Originally Posted by mosca.br View Post
    It should handle the spectial characters fine, as long as it is properly escaped in the xml file.
    How do you properly escape the characters? I used [] around the special character and reran zmzimletctl configure config.xml net_inova_gmaps and get an error (it looks to be the same error)
    You can try to use a xml editor so it escapes the characters for you, or you can change the password to a simpler one and test it.
    I changed to a simpler password and still get the error. What about the other questions:
    -what name to give this file or if it matter what name
    -where i need to be running this command from, i.e what directory (zimlets or does it matter?)
    -the mysql DB is not the mysql DB that zimbra uses, does this matter?

  4. #4
    Join Date
    Oct 2008
    Posts
    5
    Rep Power
    7

    Default

    Quote Originally Posted by carnold View Post
    How do you properly escape the characters? I used [] around the special character and reran zmzimletctl configure config.xml net_inova_gmaps and get an error (it looks to be the same error)

    I changed to a simpler password and still get the error. What about the other questions:
    -what name to give this file or if it matter what name
    -where i need to be running this command from, i.e what directory (zimlets or does it matter?)
    -the mysql DB is not the mysql DB that zimbra uses, does this matter?

    That error implies that the server is refusing the xml file, probably because of a broken syntax. You should convert your special characters to xml entities.

    What special characters are you using?

    I just tested with this simple file and it worked:

    Code:
    <zimletConfig name="Net_Inova_GMaps" version="1.0">
            <global>
                    <property name="allowedDomains">*.google.com,*.inova.com.br,*.inova.net</property>
                    <property name="dbhost">retirante</property>
                    <property name="dbuser">gmaps</property>
                    <property name="dbpass">gmaps</property>
                    <property name="dbname">gmaps</property>
                    <property name="baseCountry">br</property>
                    <property name="markerIcon">http://maps.google.com/intl/en_ALL/mapfiles/marker.png</property>
                    <property name="markerIconW">20</property>
                    <property name="markerIconH">34</property>
                    <property name="markerIconAnchorX">13</property>
                    <property name="markerIconAnchorY">35</property>
            </global>
    </zimletConfig>
    As for the other questions:
    - The name of the file does not matter at all.
    - The command should be run from a mailbox server, with the zimbra user. The directory itself, does not matter, as long as the config file is in the same directory.
    - The zimlet does not care where the mysql is, but the machine running the mailbox server must be able to connect to that mysql server with the provided credentials.

  5. #5
    Join Date
    Jul 2007
    Posts
    227
    Rep Power
    8

    Default

    The special character is <
    I have this in the file, [<] but it still chokes on it. Don't have a xml editor on this server. How do you properly escape that character?

  6. #6
    Join Date
    Oct 2008
    Posts
    5
    Rep Power
    7

    Default

    Probably, the easier way to escape your password it to place it inside a CDATA secion.

    Something along the lines of:

    Code:
    <property name="dbpass"><![CDATA[Your complex mysql password here]]></property>
    Last edited by mosca.br; 07-07-2009 at 12:34 PM.

  7. #7
    Join Date
    Jul 2007
    Posts
    227
    Rep Power
    8

    Default

    That was the first thing i tried and it would not work. What did work was &lt;
    So i sent myself a message with an address and hover my mouse over it but nothing happens. Do you have to restart the mailbox?

  8. #8
    Join Date
    Oct 2008
    Posts
    5
    Rep Power
    7

    Default

    Have you checked if the Zimlet is enabled for that account cos?

    The Zimlet will also show on the Zimlet list, under the folders on the webclient.

    If it shows up, but the address was not highlighted, you may need to change the regexps provided so that it can match the address style in your country.

    You can easily add your own regexps to net_inova_gmaps.js arround line 102.

    It will support the same regexp used by the Yahoo Maps! Zimlet and Brazilian style addresses out of the box.

    If you do change the regexps, please share them here and I'll include it on the Zimlet published on the Gallery

  9. #9
    Join Date
    Jul 2007
    Posts
    227
    Rep Power
    8

    Default

    Quote Originally Posted by mosca.br View Post
    Have you checked if the Zimlet is enabled for that account cos?
    Not exactly sure how to see if it is enabled
    The Zimlet will also show on the Zimlet list, under the folders on the webclient.
    It does show up in that list

    If it shows up, but the address was not highlighted, you may need to change the regexps provided so that it can match the address style in your country.
    It does highlight just the popup says cant find API for domain. I looked back at the google account and copied the key into the mysql DB table. Still says key not found
    When you click on the address that is highlighted, it does bring up the google maps of that address. Seems like it works when you click the link but not when you hover over the link/address.
    Oh, the map that comes up is from google brazil. The config file says US?
    Last edited by carnold; 07-07-2009 at 03:22 PM.

  10. #10
    Join Date
    Oct 2008
    Posts
    5
    Rep Power
    7

    Default

    Quote Originally Posted by carnold View Post
    Not exactly sure how to see if it is enabled

    It does show up in that list


    It does highlight just the popup says cant find API for domain. I looked back at the google account and copied the key into the mysql DB table. Still says key not found
    When you click on the address that is highlighted, it does bring up the google maps of that address. Seems like it works when you click the link but not when you hover over the link/address.
    Oh, the map that comes up is from google brazil. The config file says US?
    Are you sure the credentials for the mysql database are correct?

    Try the attached version, as I added the possibility to show some debug information to the dialog box.

    Update the zimlet and add
    Code:
    <property name="enableDebug">TRUE</property>
    to the config.xml. You may need to restart your mailbox process after updating the Zimlet.

    If debugging is enabled and there is any problem connecting to the mysql server, it will display the exception under the "key not found" message.

    You can also easily check if the Zimlet is setup correctly by accessing the jsp it uses to display the google maps output directly, like this:

    http://your.public.service.hostname....C3%A3o%20Paulo

    If you go to this url directly, you can also view source to check what the Zimlet thinks is your baseCountry and the API host it is looking for in the keymap table.

    They will both be inside a comment block in the html source, like this:
    Code:
    <!--
    Base Country: us
    DB Host: retirante
    -->
    I'll probably update the README file with the result of this discussion. Better documentation never hurts!
    Attached Files Attached Files
    Last edited by mosca.br; 07-08-2009 at 01:03 PM.

Similar Threads

  1. Replies: 21
    Last Post: 02-04-2010, 10:06 AM
  2. Outlook 2007 Beta error
    By bersrker in forum Zimbra Connector for Outlook
    Replies: 13
    Last Post: 07-17-2008, 08:38 AM
  3. Replies: 5
    Last Post: 01-11-2008, 05:34 AM
  4. Replies: 13
    Last Post: 07-20-2007, 04:21 AM
  5. Post instsallation problems
    By Assaf in forum Installation
    Replies: 14
    Last Post: 01-29-2007, 11:38 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •