Page 2 of 2 FirstFirst 12
Results 11 to 14 of 14

Thread: How to get the connected userid?

  1. #11
    Join Date
    Jan 2009
    Posts
    34
    Rep Power
    6

    Default

    Quote Originally Posted by mune72 View Post
    Unfortunally it doesn't work (I get a java compilation error)...
    It was something very silly:
    from
    Provisioning prov1 = Provisioning.getInstance();
    Account retAcct = prov1.get(AccountBy.id, my_uid);
    to
    Provisioning prov1 = Provisioning.getInstance();
    Account retAcct = prov1.get(Provisioning.AccountBy.id, my_uid);

    But now I'm quite disappointed; all this effort and everything I can get from the object <Account> retAccnt is only the account's mail adress; do you think I can retrive more?

    Thanks

  2. #12
    Join Date
    Feb 2010
    Posts
    4
    Rep Power
    5

    Default

    I have added the page import line (<%@ page import="com.zimbra.cs.account.*, com.zimbra.cs.zimlet.*" %>) but still get the "cannot be resolved" errors. Any clue of what can it be?
    I have even added the full import path to the types (e.g., " com.zimbra.cs.account.Account acct = null;" instead of just "Account acct = null;") but it still cannot resolve.

  3. #13
    Join Date
    Jan 2009
    Posts
    34
    Rep Power
    6

    Default

    Quote Originally Posted by csaguiar View Post
    I have added the page import line (<%@ page import="com.zimbra.cs.account.*, com.zimbra.cs.zimlet.*" %>) but still get the "cannot be resolved" errors. Any clue of what can it be?
    I have even added the full import path to the types (e.g., " com.zimbra.cs.account.Account acct = null;" instead of just "Account acct = null;") but it still cannot resolve.
    Unfortunelly I can't help you, it works for me and I can't guess what it could be.

  4. #14
    Join Date
    Feb 2010
    Posts
    4
    Rep Power
    5

    Default

    Quote Originally Posted by mune72 View Post
    Unfortunelly I can't help you, it works for me and I can't guess what it could be.
    Hopefully Scott or someone else from Zimbra will be able to help....

Similar Threads

  1. [SOLVED] Moving Zimbra to a new server
    By krolen in forum Administrators
    Replies: 109
    Last Post: 02-05-2009, 10:38 AM
  2. Replies: 20
    Last Post: 03-18-2008, 05:37 AM
  3. can't you help me
    By iwan siahaan in forum Administrators
    Replies: 6
    Last Post: 12-17-2007, 05:53 PM
  4. Cannot login as admin after install
    By elesouef in forum Installation
    Replies: 23
    Last Post: 02-13-2007, 08:06 AM
  5. Seeming variety of problems on suse-9.1
    By Crexis in forum Installation
    Replies: 52
    Last Post: 03-03-2006, 11:19 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •