Results 1 to 2 of 2

Thread: [SOLVED] zimlet - no such zimlet:

  1. #1
    Join Date
    Mar 2010
    Rep Power

    Default [SOLVED] zimlet - no such zimlet:

    I am trying out some of the example zimlets on the Zimlet Developer's guide. I am running ZD 1.0.4 on XP and am testing by simply dropping the zimlet in a .zip file into the _dev directory and refreshing the browser. I have tried the following zimlets :

    * Simple Tool Tip [works]
    * Custom Tool Tip [does not work]
    * Simple On Click [works]
    * Menu Items with URL actions (via XML) [works]
    * Menu Items with URL actions (via JavaScript) [does not work]

    Basically, any of the zimlets using just just the xml defiinition file work, whereas the others which use the definition file plus javascript give the following error in the log :

    2010-03-23 15:16:07,815 INFO  [btpool0-19] [] zimlet - no such zimlet: com_zimbra_example_menuitemsjs

    Has anyone encountered this before ?

    Many thanks in advance,

  2. #2
    Join Date
    Mar 2010
    Rep Power


    I figured out what the problem was - the .zip file (for example the .zip file from the examples zimlets in the Zimlet Developer's Guide) needs to be extracted so that the whole directory structure is under the _dev folder.

    For some reason, you don't have to unzip the .zip file when it only consists of the .xml definition file, but otherwise, you do.... (at least in XP)

Similar Threads

  1. Replies: 6
    Last Post: 03-05-2010, 12:13 AM
  2. Replies: 21
    Last Post: 02-04-2010, 09:06 AM
  3. Samba and POSIX undeploy problem
    By catnipper in forum Zimlets
    Replies: 0
    Last Post: 09-02-2009, 10:51 AM
  4. Outlook 2007 Beta error
    By bersrker in forum Zimbra Connector for Outlook
    Replies: 13
    Last Post: 07-17-2008, 07:38 AM
  5. Post instsallation problems
    By Assaf in forum Installation
    Replies: 14
    Last Post: 01-29-2007, 10:38 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts