Results 1 to 10 of 20

Thread: sms zimlet troubleshooting

Hybrid View

  1. #1
    Join Date
    Sep 2006
    Rep Power

    Default sms zimlet troubleshooting


    Hmmm. I would appreciate a little help if someone can point me in the right direction. I followed the general instructions to deploy the sms zimlet as per: - as I am clearly missing something.

    Steps to deply sms zimlet:

    $su - zimbra
    $cd zimlets-extras/
    $zmzimletctl deploy
    $zmzimletctl getConfigTemplate > cfg.tmp
    $vi cfg.tmp
    Changed the settings to match my account. wq!
    $zmzimletctl configure cfg.tmp
    $tomcat restart

    I should mention that my cfg.tmp looks as follows:

    <zimletConfig name="com_zimbra_sms" version="1.0">
    <property name="smsusername">MyUserName</property>
    <property name="smspassword">MyPassWord</property>
    <property name="smsfrom">SN</property>

    Where MyUserName, MyPassWord and SN are my actual detals as per I have tested via the web interface and do not have any issues with the service.

    Whenever I send a message via the sms zimlet I get: Error could not SMS +6143xxxxxxx - this is after I fudged the sms.jsp to look as follows due to the code inserting a +1 (USA) country code bit. I basically just inserted '6' - for the time being (+61 being the country code for australia) - to test the service:

    if (!phone_num.startsWith("+61")) {
    if (phone_num.startsWith("6")) {
    phone_num = "+" + phone_num;
    } else {
    phone_num = "+61" + phone_num;

    Even with this alteration I am unable to sms and still get the "Error: Unable to SMS +6143xxxxxxx" error message. I've checked over a few things but don't seem to be able to find a place to where the freaking zimlet is logging its errors. It is not logging to zimbra.log nor anywhere else I could find.

    Only thing I have not done as yet is to dump out the ldap schemer, I assume that the sms part within the default schemer was simply overwritten rather then added to everytime I have re-deployed the sms zimlet?

    Any help would be much appreciated.



    Release 4.0 on a Fedora Core 5 box.
    Last edited by switchnetworks; 09-06-2006 at 01:36 AM.

  2. #2
    Join Date
    Aug 2005
    San Mateo, CA
    Rep Power


    Try increasing the zimlet version if you changed it. We ignore changes if the version is the same.
    Looking for new beta users -> Co-Founder of Acompli. Previously worked at Zimbra (and Yahoo! & VMware) since 2005.

  3. #3
    Join Date
    Sep 2006
    Rep Power


    Increased the version. Re-checked settings. Disabled. Undeployed. Redeployed.
    Still not getting it to work. Here is a packet dump of the proceedings. All is ok until I get to the RCPT TO: bit and it fails.

    0.000000 -> TCP 49524 > smtp [FIN, ACK] Seq=0 Ack=0 Win=5840 Len=0
    11.074003 -> TCP 53245 > smtp [SYN] Seq=0 Len=0 MSS=1460
    11.254581 -> TCP smtp > 53245 [SYN, ACK] Seq=0 Ack=1 Win=16352 Len=0 MSS=1460
    11.254620 -> TCP 53245 > smtp [ACK] Seq=1 Ack=1 Win=5840 Len=0
    16.138999 -> SMTP Response: 220 SMTP service ready
    16.139305 -> TCP 53245 > smtp [ACK] Seq=1 Ack=25 Win=5840 Len=0
    16.141662 -> SMTP Command: EHLO web2
    16.331633 -> SMTP Response: 250-Requested mail action okay, completed
    16.332260 -> SMTP Command: AUTH LOGIN
    16.512656 -> SMTP Response: 334 VXNlcm5hbWU6
    16.513605 -> SMTP Message Body
    16.693929 -> SMTP Response: 334 UGFzc3dvcmQ6
    16.694229 -> SMTP Message Body
    16.890553 -> TCP smtp > 53245 [ACK] Seq=180 Ack=64 Win=16289 Len=0
    16.902296 -> SMTP Response: 235 Authentication successful
    16.939582 -> TCP 53245 > smtp [ACK] Seq=64 Ack=211 Win=5840 Len=0
    16.959489 -> SMTP Command: MAIL FROM:<>
    17.140045 -> SMTP Response: 250 Requested mail action okay, completed
    17.140352 -> TCP 53245 > smtp [ACK] Seq=108 Ack=254 Win=5840 Len=0
    17.140568 -> SMTP Command: RCPT TO:<>
    17.320933 -> SMTP Response: 503 Bad sequence of commands
    17.321898 -> SMTP Command: RSET
    17.502833 -> SMTP Response: 250 Requested mail action okay, completed
    17.539389 -> TCP 53245 > smtp [ACK] Seq=152 Ack=327 Win=5840 Len=0

  4. #4
    Join Date
    Sep 2007
    Rep Power


    Does anyone have this zimlet working yet - I have tried all the permmutations and it still won't do it

  5. #5
    Join Date
    May 2006
    Rep Power


    I had it working fine, but the sms zimlet relies on having an account at it seems they've gotten rid of their unlimited free sending; then for a bit they used to have 50/month free...

    Now, you only get '3.00 SMS Credits' for free. Then 15c/message - I really think we should explore other options...because by the time you make sure that it doesnt get hit by any spam filters/protocol checks & that the zimlet works properly, you've already used up your 3 tries, and that's certainly not enough to serve an organization.

    Yes the idea would be to buy in chunks of '1501' for your entire organization (weird # I know - but apparently you purchase in chunks of it's 50, 100, 400, 1501)
    But at 10c that's still $150. Then keeping track of who sent what if you had to tell them to slow down...doesn't seem productive.
    Last edited by mmorse; 09-13-2007 at 06:06 AM.

  6. #6
    Join Date
    Sep 2007
    Rep Power


    Hi Mike

    I set up the ipipi account yesterday and have changed the params in the files to reflect that with user name and pw etc but it just keeps saying it can't send


  7. #7
    Join Date
    Feb 2009
    Rep Power


    I have the same problem with the SMS zimlet. Has this issue been solved, or it it only me who cannot find out how to configure the SMS zimlet proberly?


Similar Threads

  1. Replies: 21
    Last Post: 02-04-2010, 10:06 AM
  2. Replies: 5
    Last Post: 01-11-2008, 05:34 AM
  3. Replies: 13
    Last Post: 07-20-2007, 04:21 AM
  4. Domain Admin Error: Permission Denied
    By shanson in forum Administrators
    Replies: 3
    Last Post: 05-29-2007, 06:48 AM
  5. Post instsallation problems
    By Assaf in forum Installation
    Replies: 14
    Last Post: 01-29-2007, 11:38 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts