Results 1 to 2 of 2

Thread: Driving me absolutely nuts

Hybrid View

  1. #1
    Join Date
    Dec 2010
    Posts
    1
    Rep Power
    4

    Default Driving me absolutely nuts

    I've had so many problems today, its just a total joke. but lets start with something basic.

    I've installed ZD2 on my mac OSX 10.6.5 and I am trying for the life of me to deploy a zimlet... which i've been trying to do literally all day, and i'm only doing it now on the desktop version because apparently (and it references this fact almost never) you have to restart mailboxd for zimlet changes to take effect. bogus. i can't do that until like midnight when nobody is using our email... so that sucks.

    so onto the desktop version, and it not working.

    java -cp jetty/lib/log4j-1.2.15.jar:jetty/common/lib/commons-httpclient-3.0.jar:jetty/common/lib/mail.jar:jetty/common/lib/commons-logging.jar:jetty/common/lib/commons-codec-1.4.jar:jetty/common/lib/json.jar:jetty/common/lib/dom4j-1.5.2.jar:jetty/common/lib/zimbracommon.jar:jetty/webapps/service/WEB-INF/lib/zimbrastore.jar:jetty/common/lib/zimbra-native.jar -Dzimbra.config=/Users/zasadab03/Library/Zimbra\ Desktop/conf/localconfig.xml com.zimbra.cs.zimlet.ZimletUtil deploy ~/Desktop/com_zimbra_tasksync.zip

    output:

    conf/localconfig.xml com.zimbra.cs.zimlet.ZimletUtil deploy ~/Desktop/com_zimbra_tasksync.zip
    Fatal error: terminating: Failed to loadLibrary(zimbra-native)
    java.lang.UnsatisfiedLinkError: no zimbra-native in java.library.path
    at java.lang.ClassLoader.loadLibrary(ClassLoader.java :1754)
    at java.lang.Runtime.loadLibrary0(Runtime.java:823)
    at java.lang.System.loadLibrary(System.java:1045)
    at com.zimbra.znative.Util.loadLibrary(Util.java:38)
    at com.zimbra.znative.Util.<clinit>(Util.java:54)
    at com.zimbra.common.net.ProxySelectors.useNativeProx ySelector(ProxySelectors.java:51)
    at com.zimbra.common.net.ProxySelectors.<clinit>(Prox ySelectors.java:41)
    at com.zimbra.common.net.SocketFactories.register(Soc ketFactories.java:92)
    at com.zimbra.common.net.SocketFactories.registerProt ocols(SocketFactories.java:69)
    at com.zimbra.common.net.SocketFactories.registerProt ocols(SocketFactories.java:59)
    at com.zimbra.common.util.CliUtil.toolSetup(CliUtil.j ava:34)
    at com.zimbra.common.util.CliUtil.toolSetup(CliUtil.j ava:29)
    at com.zimbra.common.util.CliUtil.toolSetup(CliUtil.j ava:25)
    at com.zimbra.cs.zimlet.ZimletUtil.main(ZimletUtil.ja va:1890)

    WHY!?

  2. #2
    Join Date
    Apr 2007
    Location
    Paris, France
    Posts
    367
    Rep Power
    8

    Default

    Since you are using ZD2, why do you use CLI?

    In ZD2, preferences tab, you have a zimlet section that allow you to upload/install zimlet on ZD.
    Did you tested it?

Similar Threads

  1. Getting nuts with postfix outlook and thunderbird
    By haensse in forum Installation
    Replies: 2
    Last Post: 03-27-2007, 02:17 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •