Results 1 to 7 of 7

Thread: zmzimletctl not working

Hybrid View

  1. #1
    Join Date
    Nov 2006
    Posts
    2
    Rep Power
    10

    Default zmzimletctl not working

    Hello,

    I just installed Zimbra in my test environment and everything seems to be running just fine. However I wanted to try some zimlets, I went to the directory per instructions and tried to run zmzimletctl deploy <zipfile>.

    However all I get is a "bash: zmzimletctl: command not found" error message. Every time I try running zmzimletctl I get the same message.

    Thanks for your help,

    Leon

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    59

    Default

    Did you run the command as the zimbra user (su - zimbra)?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    Join Date
    Oct 2006
    Posts
    103
    Rep Power
    10

    Default

    Quote Originally Posted by phoenix
    Did you run the command as the zimbra user (su - zimbra)?
    ^^^ What he said. All 'zm' commands must be run as "su - zimbra".

  4. #4
    Join Date
    Nov 2006
    Posts
    2
    Rep Power
    10

    Default

    Quote Originally Posted by phoenix
    Did you run the command as the zimbra user (su - zimbra)?
    Yes that was it. Thanks, feel so stupid.

  5. #5
    Join Date
    Oct 2006
    Posts
    103
    Rep Power
    10

    Default

    Quote Originally Posted by Leon Nichols
    Yes that was it. Thanks, feel so stupid.
    Don't. Can't tell you how many times I've done that. lol

  6. #6
    Join Date
    Jan 2007
    Posts
    1
    Rep Power
    10

    Default unable to run zimblets

    HI,

    I am very new.. just installed zimbra a couple of days back... I get the error below when try to activate zimlets.. please guide

    [root@fc51322 zimbra]# cd zimlets-extra
    [root@fc51322 zimlets-extra]# ls -al
    total 884
    drwxrwxr-x 2 zimbra zimbra 4096 Dec 30 23:43 .
    drwxr-xr-x 39 root root 4096 Dec 31 00:04 ..
    -rw-rw-r-- 1 zimbra zimbra 52990 Dec 18 08:02 com_flightexplorer_fasttrack.zip
    -rw-rw-r-- 1 zimbra zimbra 4557 Dec 18 08:02 com_zimbra_amzn.zip
    -rw-rw-r-- 1 zimbra zimbra 217770 Dec 18 08:02 com_zimbra_arcade.zip
    -rw-rw-r-- 1 zimbra zimbra 4712 Dec 18 08:02 com_zimbra_asteriskmwi.zip
    -rw-rw-r-- 1 zimbra zimbra 410673 Dec 18 08:02 com_zimbra_asterisk.zip
    -rw-rw-r-- 1 zimbra zimbra 1110 Dec 18 08:02 com_zimbra_bugz.zip
    -rw-rw-r-- 1 zimbra zimbra 4316 Dec 18 08:02 com_zimbra_collector.zip
    -rw-rw-r-- 1 zimbra zimbra 4651 Dec 18 08:02 com_zimbra_evite.zip
    -rw-rw-r-- 1 zimbra zimbra 4537 Dec 18 08:02 com_zimbra_gtranslator.zip
    -rw-rw-r-- 1 zimbra zimbra 1372 Dec 18 08:02 com_zimbra_jspsample.zip
    -rw-rw-r-- 1 zimbra zimbra 45051 Dec 18 08:02 com_zimbra_photo.zip
    -rw-rw-r-- 1 zimbra zimbra 6138 Dec 18 08:02 com_zimbra_po.zip
    -rw-rw-r-- 1 zimbra zimbra 4806 Dec 18 08:02 com_zimbra_rss.zip
    -rw-rw-r-- 1 zimbra zimbra 15645 Dec 18 08:02 com_zimbra_sforce.zip
    -rw-rw-r-- 1 zimbra zimbra 5338 Dec 18 08:02 com_zimbra_sms.zip
    -rw-rw-r-- 1 zimbra zimbra 1690 Dec 18 08:02 com_zimbra_tracking.zip
    -rw-rw-r-- 1 zimbra zimbra 25462 Dec 18 08:02 com_zimbra_travelagent.zip
    -rw-rw-r-- 1 zimbra zimbra 3018 Dec 18 08:02 com_zimbra_wikipedia.zip
    -rw-rw-r-- 1 zimbra zimbra 13064 Dec 18 08:02 com_zimbra_xslt.zip
    -rw-rw-r-- 1 zimbra zimbra 3897 Dec 18 08:02 com_zimbra_ymaps.zip
    -rw-rw-r-- 1 zimbra zimbra 3637 Dec 18 08:02 com_zimbra_ytraffic.zip
    [root@fc51322 zimlets-extra]# su - zimbra
    [zimbra@fc51322 ~]$ zmzimletctl deploy com_zimbra_ymaps.zip
    Error: Zimlet not found: com_zimbra_ymaps.zip

    Regards
    Xtendz

  7. #7
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    59

    Default

    When you do an 'su - zimbra' you need to cd to the ~/zimlets-extra directory. Do an 'ls -al' after you've done the su and you'll see you're not in that directory.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

Similar Threads

  1. I got Ubuntu and Zimbra working
    By pacsteel in forum Installation
    Replies: 73
    Last Post: 06-23-2008, 11:41 AM
  2. Replies: 5
    Last Post: 10-19-2006, 02:25 AM
  3. Zimbra stoped working overnight
    By vlskip in forum Installation
    Replies: 32
    Last Post: 03-07-2006, 12:52 PM
  4. antispam not working?
    By moebis in forum Installation
    Replies: 16
    Last Post: 12-03-2005, 07:11 PM
  5. HTTPS Is Working, HTTP Not Working
    By uh-nu-bu in forum Installation
    Replies: 12
    Last Post: 11-09-2005, 05:58 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •