Page 2 of 2 FirstFirst 12
Results 11 to 12 of 12

Thread: SxpSugar & zSugar

  1. #11
    Join Date
    Mar 2011
    Rep Power


    when i click status the zimlet show yhis message "Your session is authenticated."

    i think the connection is ok

    when i click in ok button (the popup in the image) i have this message "there is a query beginning processed "

    how i can know if zimlet work correctly with sugarcrm server ?

  2. #12
    Join Date
    Nov 2011
    Rep Power


    same things are happening to me when i'm in development mode (extracting scripts in _dev folder) and i don't know why?!

    you should put all scripts in zip package, and deploy it.
    after that, reload zimbra and that should be it.
    i know how to deploy on our server, but locally on win i have no idea.


    i have read almost every tutorial about deploying zimlet,
    but none of them are helpfull (talking about zimbra desktop).

    ..positioning in cmd to: c>users>appdata>local>zimbra>zimbra desktop and
    java -cp jetty/lib/*;jetty/common/lib/*;jetty/webapps/service/WEB-INF/lib/* -Dzimbra.config=conf/localconfig.xml com.zimbra.cs.zimlet.ZimletUtil deploy zimlets/

    but every time i get an:

    Exception in thread "main" java.lang.NoClassDefFoundError: com/zimbra/cs/zimlet/ZimletUtil
    Caused by: java.lang.ClassNotFoundException: com.zimbra.cs.zimlet.ZimletUtil
    at$ Source)
    at Method)
    at Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at java.lang.ClassLoader.loadClassInternal(Unknown Source)
    Could not find the main class: com.zimbra.cs.zimlet.ZimletUtil. Program will exit.

    i tried with "/" and "\", with ":" and ";"
    tried also from c:\program files\zimbra\zimbra desktop,
    tried to put zimlet in zimlets directory, tried to put it on desktop...
    tried to change "zimlets/" to c:\program files\zimbra\zimbra desktop\zimlets\ ->{path to the zimlet}

    but errors are the same
    what to do?
    pls help!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts