Results 1 to 5 of 5

Thread: How to completely remove userProperties ?

  1. #1
    Join Date
    Jul 2012
    Location
    Algiers
    Posts
    55
    Rep Power
    3

    Default [SOLVED] How to completely remove userProperties ?

    Code:
    [I want to delete those properties]
    s15389121:/opt/zimbra/bin # ./zmprov ma yassine@clarten.fr -zimbraZimletUserProperties "com_feeder_sugarbee:passwd:"
    s15389121:/opt/zimbra/bin # ./zmprov ma yassine@clarten.fr -zimbraZimletUserProperties "com_feeder_sugarbee:password:"
    s15389121:/opt/zimbra/bin # ./zmprov ma yassine@clarten.fr -zimbraZimletUserProperties "com_feeder_sugarbee:username:"
    
    [Let's make sure they were removed...]
    s15389121:/opt/zimbra/bin # ./zmprov ga yassine@clarten.fr zimbraZimletUserProperties | grep feeder
    zimbraZimletUserProperties: com_feeder_sugarbee:sb_username:yassine
    zimbraZimletUserProperties: com_feeder_sugarbee:sb_saved_appts_ids:["4c9c3296-df12-6ced-0c08-50894961cb22"]
    zimbraZimletUserProperties: com_feeder_sugarbee:sb_sugar_url:http://92.1.52.30/sugarcrm
    zimbraZimletUserProperties: com_feeder_sugarbee:sb_password:xxxxxxx
    
    [ great, they're gone...]
    
    [ Now, refreshing the browser, double click on the zimlet to show the properties editor... They're still there !]
    
    s15389121:/opt/zimbra/bin # ./zmprov ga yassine@clarten.fr zimbraZimletUserProperties | grep feeder
    zimbraZimletUserProperties: com_feeder_sugarbee:sb_username:yassine
    zimbraZimletUserProperties: com_feeder_sugarbee:sb_password:xxxxxxx
    zimbraZimletUserProperties: com_feeder_sugarbee:password: <------
    zimbraZimletUserProperties: com_feeder_sugarbee:username: <------ Hey, you >:( you were all deleted, why are you still here ?
    zimbraZimletUserProperties: com_feeder_sugarbee:passwd: <------
    zimbraZimletUserProperties: com_feeder_sugarbee:sb_saved_appts_ids:["4c9c3296-df12-6ced-0c08-50894961cb22"]
    zimbraZimletUserProperties: com_feeder_sugarbee:sb_sugar_url:http://92.1.52.30/sugarcrm
    s15389121:/opt/zimbra/bin 
    #

    Knowing that those three properties :

    1. Are not in any javascript files
    2. Are not in any XML file, neither com_feeder_sugarbee.xml nor config_template.xml

    They were removed from these files.


    Any help appreciated.
    Last edited by ychaouche; 12-03-2012 at 08:09 AM.

  2. #2
    Join Date
    Jul 2012
    Location
    Algiers
    Posts
    55
    Rep Power
    3

    Default

    Update :

    1/ I removed the properties
    2/ I removed the zimlet (undeployed it in the admin interface)
    3/ I deployed the zimlet again
    4/ I refreshed the browser, the zimlet showed up, the properties are not shown in zmprov but are present in the zimlet property editor AGAIN.

    Where could the zimlet get these properties from if they're not in any file ?

  3. #3
    Join Date
    Jul 2012
    Location
    Algiers
    Posts
    55
    Rep Power
    3

    Default

    I don't know if this is coincidence or not, but as I didn't have any clue whatsoever, here's what I thought I'd do :
    1/ copy the zimlet and change its name
    2/ change the ZDF name accordingly, and change the name attribute of its zimlet element.
    3/ change the attribute names.

    I deployed this zimlet and kept the old. I forgot to deploy the zimlet in the appropriate CoSs and domains

    I refereshed the browser and saw the old zimlet, but when I showed up the property editor the old properties have gone away O_o'

    So I'm putting solved for the moment.

  4. #4
    Join Date
    Oct 2009
    Location
    Tokyo
    Posts
    113
    Rep Power
    6

    Default

    Your environment is multi-server environment?

    If so, server side cache could be the reason for that.

  5. #5
    Join Date
    Jul 2012
    Location
    Algiers
    Posts
    55
    Rep Power
    3

    Default

    I'm not sure know what do you mean by multi-server environement. The OS is virtualized, and we have only one zimbra server on that OS. I also made sure to empty Zimbra cache both on the command line and on the zimbra administration interface but that didn't solve the problem.

Similar Threads

  1. Problem with userProperties
    By ankurankan in forum Zimlets
    Replies: 2
    Last Post: 10-01-2012, 05:38 AM
  2. Completely remove memcached
    By mlanner in forum Administrators
    Replies: 7
    Last Post: 05-05-2012, 08:36 AM
  3. Horrible Experince - How do I completely remove ZD?
    By rustyw007 in forum General Questions
    Replies: 1
    Last Post: 05-09-2011, 11:04 PM
  4. [SOLVED] Remove the reply button completely from all skins?
    By Meowmixjinx in forum Administrators
    Replies: 3
    Last Post: 12-30-2010, 12:44 PM
  5. visible not working in userproperties
    By anands in forum Zimlets
    Replies: 2
    Last Post: 10-27-2008, 10:26 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •