As ZD does not have zmzimletctl util I'm trying to deploy "hello world" zimlet by following command

Code:
java -cp ../jetty/lib/log4j-1.2.16.jar:../jetty/common/lib/commons-httpclient-3.1.jar:../jetty/common/lib/mail.jar:../jetty/common/lib/commons-logging.jar:../jetty/common/lib/commons-codec-1.4.jar:../jetty/common/lib/json.jar:../jetty/common/lib/dom4j-1.5.2.jar:../jetty/common/lib/zimbracommon.jar:../jetty/webapps/service/WEB-INF/lib/zimbrastore.jar:../jetty/common/lib/guava-r09.jar:../jetty/common/lib/zimbra-native.jar -Dzimbra.config=conf/localconfig.xml -Djava.library.path=../lib/ com.zimbra.cs.zimlet.ZimletUtil deploy zimlets/com_zimbra_hello.zip
but got this error

Code:
Fatal error: terminating: Failed to loadLibrary(zimbra-native)
java.lang.UnsatisfiedLinkError: /opt/zimbra/zdesktop/lib/libzimbra-native.so: /opt/zimbra/zdesktop/lib/libzimbra-native.so: wrong ELF class: ELFCLASS32 (Possible cause: architecture word width mismatch)
	at java.lang.ClassLoader$NativeLibrary.load(Native Method)
	at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1807)
	at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1732)
	at java.lang.Runtime.loadLibrary0(Runtime.java:823)
	at java.lang.System.loadLibrary(System.java:1028)
	at com.zimbra.znative.Util.loadLibrary(Util.java:38)
	at com.zimbra.znative.Util.<clinit>(Util.java:54)
	at com.zimbra.common.net.ProxySelectors.useNativeProxySelector(ProxySelectors.java:63)
	at com.zimbra.common.net.ProxySelectors.<clinit>(ProxySelectors.java:43)
	at com.zimbra.common.net.SocketFactories.register(SocketFactories.java:92)
	at com.zimbra.common.net.SocketFactories.registerProtocols(SocketFactories.java:69)
	at com.zimbra.common.net.SocketFactories.registerProtocols(SocketFactories.java:59)
	at com.zimbra.common.util.CliUtil.toolSetup(CliUtil.java:41)
	at com.zimbra.common.util.CliUtil.toolSetup(CliUtil.java:36)
	at com.zimbra.common.util.CliUtil.toolSetup(CliUtil.java:32)
	at com.zimbra.cs.zimlet.ZimletUtil.main(ZimletUtil.java:1893)
How to solve this?

How to deploy a zimlet manually?

System: Ubuntu 12.04 x86-64