Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: iframe zimlet

  1. #1
    Join Date
    Jun 2013
    Posts
    2
    Rep Power
    2

    Default iframe zimlet

    hi,
    plz I developed iframe zimlet that call a web page iframe
    but when i clic in tabpannel a blank page displayed
    plz help

  2. #2
    Join Date
    Apr 2007
    Location
    Paris, France
    Posts
    367
    Rep Power
    8

    Default

    We can't really help you with this few informations.
    The only problem I can suppose you have is that the target site is blocking iframes.

  3. #3
    Join Date
    Jul 2012
    Location
    florida
    Posts
    2
    Rep Power
    3

    Default

    Look at this first... ZCS 6.0:Zimlet Developers Guide:Examples:Tab iFrame - Zimbra :: Wiki
    Then, install and run it (If you have a Dev environment).
    Now, change all the references to the "com_zimbra_example_tabiframe" to yours in both files ie: "com_zimbra_voicemail_tabiframe" or similar..
    Now, really IMPORTANT !!! if the site you are putting in the iframe is NOT in your local Zimbra domail it HAS to be added to the
    Allowed PROXY Domains that zimlets can access from your server or it will NOT load. (at least this is how it's worked for me)
    In the Admin Console go to "Class of Service" --->Default-->Advanced-->Look in the "Proxy Allowed Domains" section & add the external domain.

  4. #4
    Join Date
    Oct 2013
    Location
    Denmark
    Posts
    30
    Rep Power
    2

    Default

    Hey all,

    I'm having the same issue on my Zimbra version 8 installation.

    Even when I just upload the default zimlet it just goes blank. default being Yahoo - i would assume that would work??

    I have also been to the zimlet site

    ZCS 6.0:Zimlet Developers Guide:Examples:Tab iFrame - Zimbra :: Wiki

    I don't know but when i read through the site i get the feeling the problem maybe that zimbra version 8 isn't supported with this zimlet? could that be?

    THANKS

    Casper

    Could the problem be that i'm running 8.0?

  5. #5
    Join Date
    Jun 2013
    Posts
    23
    Rep Power
    2

    Default

    I don't think the problem is the 8.0 version of Zimbra, because I've developed many Zimlets under Zimbra 8 in that manner...
    Can you upload the code?

  6. #6
    Join Date
    Oct 2013
    Location
    Denmark
    Posts
    30
    Rep Power
    2

    Default

    Hi g41n

    as i wrote in my former post the zimlet doesn't work even if use the standard code that is supplied with it.. IE yahoo.com should appear as a tap..

    In my former post i link to where you can download the zimlet.. from there you can see the code..

    THANKS for answering!

    Casper

  7. #7
    Join Date
    Jun 2013
    Posts
    23
    Rep Power
    2

    Default

    Quote Originally Posted by offerlam22 View Post
    Hi g41n

    as i wrote in my former post the zimlet doesn't work even if use the standard code that is supplied with it.. IE yahoo.com should appear as a tap..

    In my former post i link to where you can download the zimlet.. from there you can see the code..

    THANKS for answering!

    Casper
    Just tried it.

    Google Chrome say that my Zimbra installation is https and Yahoo site is http, so prevents the iframe inclusion:
    Code:
    [blocked] The page at 'https://localhost:444/?dev=1#1' was loaded over HTTPS, but ran insecure content from 'http://www.yahoo.com/': this content should also be loaded over HTTPS.
    Trying with the same protocol (ie: https://www.google.it/ or using http in Zimbra enabling with zmtlsctl both && zmcontrol restart) changes the error:
    Code:
    Refused to display 'http://it.yahoo.com/?p=us' in a frame because it set 'X-Frame-Options' to 'SAMEORIGIN'.
    With https://en.wikipedia.org it works, because its X-Frame-Options is not set to SAMEORIGIN and uses the same protocol of my Zimbra installation.
    All depends on what you need to include.

    Anyway is a browser security/destination site issue, not a Zimlet issue...

    Hope it helps.
    YetOpen S.r.l. ~ Your open source partner
    Lecco (LC) - ITALY
    http://www.yetopen.it

  8. #8
    Join Date
    Oct 2013
    Location
    Denmark
    Posts
    30
    Rep Power
    2

    Default

    Hi G41N

    Just to make sure i understood you right... it doesn't work because when i log into zimbra i use https and from there the new tap tries to be opend to a site with http... no SSL am i right?

    so following that logic all sites would work if i just point to the sites https site and not http?

    Thanks
    Casper

  9. #9
    Join Date
    Jun 2013
    Posts
    23
    Rep Power
    2

    Default

    Quote Originally Posted by offerlam22 View Post
    Hi G41N

    Just to make sure i understood you right... it doesn't work because when i log into zimbra i use https and from there the new tap tries to be opend to a site with http... no SSL am i right?

    so following that logic all sites would work if i just point to the sites https site and not http?
    Yes, but only if:
    1. The site have a SSL version (quite obvious nowadays, but not always)
    2. The site have no restrictions (for example google and twitter have restrictions as mentioned above, wikipedia works instead)



    Inviato dal mio Galaxy Nexus utilizzando Tapatalk
    Last edited by g41n; 11-25-2013 at 08:30 AM.
    YetOpen S.r.l. ~ Your open source partner
    Lecco (LC) - ITALY
    http://www.yetopen.it

  10. #10
    Join Date
    Oct 2013
    Location
    Denmark
    Posts
    30
    Rep Power
    2

    Default

    Hi G41N

    Thanks.. i think SSL was the problem.. the internal site that i tried to add as a tap was using ssl.. but it was suppose to anyways after testing was done so i will just speed that process op...

    Thanks!!
    Casper

Similar Threads

  1. Replies: 0
    Last Post: 08-20-2012, 01:02 PM
  2. Google Docs Tab iFrame
    By PaulyC in forum Zimlets
    Replies: 3
    Last Post: 05-30-2012, 10:27 AM
  3. Panel using an iFrame Example Zimlet
    By bku09 in forum Developers
    Replies: 1
    Last Post: 04-18-2010, 07:53 PM
  4. Iframe Zimbra?
    By jputz12 in forum Developers
    Replies: 6
    Last Post: 12-04-2009, 09:48 AM
  5. iFrame Zimlet
    By jisenburg in forum Zimlets
    Replies: 1
    Last Post: 04-08-2009, 02:29 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •