Results 1 to 6 of 6

Thread: Form not getting opened up when clicking content in email

  1. #1
    Join Date
    Feb 2007
    Posts
    32
    Rep Power
    8

    Default Form not getting opened up when clicking content in email

    Hello,

    I am trying to open a from when clicking particular content in email body.But its nto working.

    This is my code .Please have a look at it and let me know where i am wrong and how to rectify the same.

    Code:
    <zimlet name="com_zimlet1" version="1.0" description="zimlet1">
    	<contentObject>
    		<matchOn>
    			<regex attrs="ig">Desired Target</regex>
    		</matchOn>	
    		<toolTip>Click to open form</toolTip>
    		<onClick>
    			<canvas type="window" width="300" height="600"/>
    			
    			<formEditor name="dataEntryForm">
    				<field type="string" name="firstName" label="First Name" minLength="0" maxLength="50" visualType="inputField" />
    				<field type="string" name="lastName" label="Last Name" minLength="0" maxLength="50" visualType="inputField" />
    				<field type="date" name="dob" label="Date Of Birth"/>
    				<field type="enum" name="fruit" label="Select Fruit" >
    					<item value="Apple" visualType="select"/>
    					<item value="Grapes" visualType="select"/>
    					<item value="Orange" visualType="select"/>
    					<item value="Banana" visualType="select"/>
    				</field>
    			</formEditor>
    		</onClick>
    	</contentObject>
    </zimlet>
    Thanks.

  2. #2
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    19

    Default

    You might be better off just looking at a Zimlet that already does something similar to what you want. Not sure the canvas with embedded formEditor has been used that much.
    Looking for new beta users -> Co-Founder of Acompli. Previously worked at Zimbra (and Yahoo! & VMware) since 2005.

  3. #3
    Join Date
    Feb 2007
    Posts
    32
    Rep Power
    8

    Default

    Hi Kevin,

    Didn't get you....Can you please elaborate on what to do??

    Thanks.

  4. #4
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    19

    Default

    Try creating your Zimlet based on one of the samples. The method your using is not well tested and may not work.
    Looking for new beta users -> Co-Founder of Acompli. Previously worked at Zimbra (and Yahoo! & VMware) since 2005.

  5. #5
    Join Date
    Feb 2007
    Posts
    32
    Rep Power
    8

    Default

    So are u suggesting to use a mix of javascript and Ajax ???If yes, then please let me know from which of the default zimlets i can get better exposure to the thing i want to achieve..

    Thanks...

  6. #6
    Join Date
    Aug 2008
    Posts
    1
    Rep Power
    7

    Default

    Could you point me to an example that actually uses formEditor? I can't find a single example that actually uses one. I'm trying to do the same thing as the OP, and having the same issue.

Similar Threads

  1. need advice on configuring zimbra to work with fax server
    By pheonix1t in forum Administrators
    Replies: 0
    Last Post: 07-11-2007, 07:46 PM
  2. Can't start Zimbra!
    By zibra in forum Administrators
    Replies: 5
    Last Post: 03-22-2007, 11:34 AM
  3. upgrade to 4.0.3 antispam does'nt work
    By lucanannipieri in forum Administrators
    Replies: 14
    Last Post: 11-07-2006, 02:56 AM
  4. email -->php form. is this possible?
    By c4l3b in forum Zimlets
    Replies: 3
    Last Post: 10-13-2006, 12:24 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •