Results 1 to 5 of 5

Thread: Salesforce Zimlet Error Message

  1. #1
    Join Date
    Oct 2006
    Posts
    18
    Rep Power
    9

    Default Salesforce Zimlet Error Message

    Hi all!

    I'm trying to get the Salesforce zimlet to "talk" to my Salesforce account via the Salesforce zimlet in Zimbra. However, when I try to drag/drop to the Zimlet, I get a message stating: API_DISABLED_FOR_ORG: API is not enabled.

    My understanding (from what Salesforce has told me) is that the API comes with the Enterprise edition, however I keep getting this error in the Zimbra web interface....

    Any ideas on what I need to do to get this thing to work?

    Many thanks!

  2. #2
    Join Date
    Apr 2006
    Location
    Williamsburg, VA
    Posts
    451
    Rep Power
    9

    Default

    Looks like the web api isn't enabled - You need to make sure the web api in Salesforce is enabled for your account. You can get it as an add-on for your Professional account and it comes with the two higher levels.

  3. #3
    Join Date
    Oct 2006
    Posts
    18
    Rep Power
    9

    Default Salesforce Zimlet still not working -

    gmsmith,

    Thanks for the information, however I'm still getting the error message on a higher than Professional level account - Enterprise edition. The Zimlet is working fine in a Salesforce Developer edition, but I haven't been able to get it to work under either Professional Edition or Enterprise edition, which leads me to believe it's a problem on Salesforce's side - maybe I need to turn something on/off in my account?

    Salesforce doesn't seem to knowledgeable about the Zimlet, so really looking for any users out there that have been able to get it to work under Enterprise edition, and what steps they had to follow to get it to work!

  4. #4
    Join Date
    Oct 2010
    Posts
    373
    Rep Power
    5

    Default hey

    cirrus_blue,

    Yeah I know this thread is pretty old but still trying my luck here. Because I hope you got it working. I get the same error while trying with a salesforce account "API is not enabled for this organisation". How did you fix it? I believe this is either professional or enterprise, and definitely not a trial one. Any thoughts on what could be denying it? Using the latest 2.0 salesforce zimlet.

    Is there any way we can confirm if his account is API enabled?

  5. #5
    Join Date
    Dec 2010
    Posts
    1
    Rep Power
    4

    Default SF zimlet error

    Hello,

    I get the following error message after configuring sf zimlet 3.1 to log into SF on launch:

    e.getTreeItemById is not a function

    When I tried to send & add the salesforce search box in the popup just spins and spins.

    Any suggestions? Here's my zimbra desktop info:
    zimbra desktop 2.0 (build 10580)

    Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.3) Gecko/20100402 Prism zdesktop/2.0

    Thx,
    David

Similar Threads

  1. Replies: 21
    Last Post: 02-04-2010, 09:06 AM
  2. Replies: 5
    Last Post: 01-11-2008, 04:34 AM
  3. Replies: 13
    Last Post: 07-20-2007, 03:21 AM
  4. Domain Admin Error: Permission Denied
    By shanson in forum Administrators
    Replies: 3
    Last Post: 05-29-2007, 05:48 AM
  5. Post instsallation problems
    By Assaf in forum Installation
    Replies: 14
    Last Post: 01-29-2007, 10:38 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •