Page 1 of 3 123 LastLast
Results 1 to 10 of 25

Thread: Aruna URL zimlet issues

  1. #1
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

    Default Aruna URL zimlet issues

    See here for Aruna URL & Send file zimlets
    carefull with sending sensitive files-even though it makes a random number-they are available to all via http 5 downloads or 7 days whichever comes first
    http://gallery.zimbra.com/gallery.ph...d&productId=55

    With both the aruna URL and regular snapr (com_zimbra_url) zimlets turned on:
    Snapr works fine
    Aruna doesn't show up on right click
    1. Right click on any URL inside of an email to make it small
    2. Click on the Aruna URL zimlet to enter any link
    -highlights URLs in an email.
    Turn off the snapr leave aruna on-and after a tomcat restart:
    no url's are highlighted
    no right click menu

    Is the use of both possible/they don't override one another?
    Has anyone got the right click for aruna to show up?

  2. #2
    Join Date
    Nov 2006
    Location
    Bordeaux, France
    Posts
    140
    Rep Power
    8

    Default

    Aruna send zimlet don't want to install on ZCS 4.5.5 enterprise edition.

  3. #3
    Join Date
    Sep 2006
    Posts
    12
    Rep Power
    9

    Default

    Quote Originally Posted by NOZIL View Post
    Aruna send zimlet don't want to install on ZCS 4.5.5 enterprise edition.
    Hmm, interesting, we use that very version for our internal testing and have no problems with the installation. Perhaps you tried to install the zip file downloaded from Zimlets - Aruna Tools ? It isn't the Zimlet, that file contains some documentation and the actual Zimlet, try to unzip it and deploy the Zimlet inside of it instead.

    If thats not the issue, what error messages do you get?

  4. #4
    Join Date
    Sep 2006
    Posts
    12
    Rep Power
    9

    Default

    Quote Originally Posted by mmorse View Post
    See here for Aruna URL & Send file zimlets
    carefull with sending sensitive files-even though it makes a random number-they are available to all via http 5 downloads or 7 days whichever comes first
    Get or contribute Zimlets, UI themes, and languages in the Zimbra Gallery - Aruna URL

    With both the aruna URL and regular snapr (com_zimbra_url) zimlets turned on:
    Snapr works fine
    Aruna doesn't show up on right click
    Turn off the snapr leave aruna on-and after a tomcat restart:
    no url's are highlighted
    no right click menu

    Is the use of both possible/they don't override one another?
    Has anyone got the right click for aruna to show up?
    Interesting, we are having a peek at the issue now, we'll post what we find out here soon.

  5. #5
    Join Date
    Nov 2006
    Location
    Bordeaux, France
    Posts
    140
    Rep Power
    8

    Default

    Quote Originally Posted by gaspode View Post
    Hmm, interesting, we use that very version for our internal testing and have no problems with the installation. Perhaps you tried to install the zip file downloaded from Zimlets - Aruna Tools ? It isn't the Zimlet, that file contains some documentation and the actual Zimlet, try to unzip it and deploy the Zimlet inside of it instead.

    If thats not the issue, what error messages do you get?
    I tried to unzip the file downloaded but it seems to be corrupted. And tried to download it again using firefox or ie and it's still corrupted.

  6. #6
    Join Date
    Sep 2006
    Posts
    12
    Rep Power
    9

    Default

    Quote Originally Posted by NOZIL View Post
    I tried to unzip the file downloaded but it seems to be corrupted. And tried to download it again using firefox or ie and it's still corrupted.
    Oops, sorry, the fault was on our end. It has been corrected now, so could you please try again?

  7. #7
    Join Date
    Nov 2006
    Location
    Bordeaux, France
    Posts
    140
    Rep Power
    8

    Default

    Install works fine now with correct file

    BUT, send fail with an error box as you can see
    Attached Images Attached Images

  8. #8
    Join Date
    Sep 2006
    Posts
    12
    Rep Power
    9

    Default

    Quote Originally Posted by NOZIL View Post
    Install works fine now with correct file

    BUT, send fail with an error box as you can see
    Hmm, strange. It is probably related to the allowedDomains COS parameter on your Zimbra server, but that should have been set from the config_template.xml when you installed the Zimlet.
    How did you install the Zimlet?

  9. #9
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

    Default

    Hey gaspode,
    forgot to mention-i've finally seen the right click

    However, one thing I noticed-it works on addresses@domain.com-and it often takes the place of the useful normal right click for addresses (send email to, save to address book, etc).

    Kinda does this at random (aruna and the normal right click features fight for dominance)
    ...really who has a email address they need to make into a short url?

  10. #10
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

    Default

    btw it only happens when the address has <> symbols on the ends
    Code:
    <user@domain.com>
    where as without the <> it's fine
    Code:
    user@domain.com

Similar Threads

  1. Replies: 21
    Last Post: 02-04-2010, 09:06 AM
  2. Replies: 5
    Last Post: 01-11-2008, 04:34 AM
  3. Replies: 13
    Last Post: 07-20-2007, 03:21 AM
  4. Domain Admin Error: Permission Denied
    By shanson in forum Administrators
    Replies: 3
    Last Post: 05-29-2007, 05:48 AM
  5. Post instsallation problems
    By Assaf in forum Installation
    Replies: 14
    Last Post: 01-29-2007, 10:38 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •