Results 1 to 9 of 9

Thread: [SOLVED] Installing zimbra_posixaccount and zimbra_samba fails

Hybrid View

  1. #1
    Join Date
    Jun 2007
    Posts
    8
    Rep Power
    8

    Default [SOLVED] Installing zimbra_posixaccount and zimbra_samba fails

    Dear all,

    I'm trying to install these Zimlets to my server, using the admin interface.

    OS: Ubuntu 6.0.6 TSL
    Zimbra: 4.5.5

    I get the following trace in /opt/zimbra/log/mailbox.log:

    java.lang.NegativeArraySizeException
    at com.zimbra.cs.zimlet.ZimletFile$ZimletRawEntry.<in it>(ZimletFile.java:113)
    at com.zimbra.cs.zimlet.ZimletFile.initialize(ZimletF ile.java:179)
    at com.zimbra.cs.zimlet.ZimletFile.<init>(ZimletFile. java:154)
    at com.zimbra.cs.service.admin.DeployZimlet$DeployThr ead.run(DeployZimlet.java:99)
    at java.lang.Thread.run(Thread.java:595)

    Any ideas are greatly appreciated!

    Thanks,
    Alex

  2. #2
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

    Default

    Last edited by mmorse; 08-01-2007 at 12:57 PM. Reason: fixed subsection link

  3. #3
    Join Date
    Jun 2007
    Posts
    8
    Rep Power
    8

    Default

    Yes, I did. It seems, that the zimlet can be deployed but not installed. Is there another log file where I can have a look at?

    Is there a way to find out, if zimbraldaputils.jar has been installed correctly - does the zimlet relay on this?

  4. #4
    Join Date
    Jun 2007
    Posts
    8
    Rep Power
    8

    Exclamation Solved

    I created the zip archive on MAC OS X and got the described error. I did the same on Linux and it works now!

  5. #5
    Join Date
    May 2007
    Posts
    98
    Rep Power
    8

    Default

    I'm struggling at the same step - deploy of zimbraPosixAccount fails.

    I reckon it's the modification of the zipfile with updated dc values that causes me problems.

    ZCS 4.5.6 - OS Debian Etch

    As far as I can tell, the zimbraldaputils.jar is installed.
    ---
    2007-08-01 00:17:24,728 INFO [main] [] soap - Adding service ZimbraLDAPUtilsService to AdminServlet
    2
    ----

    mail.log excerpt:
    2007-08-01 01:11:55,161 INFO [Thread-180] [] zimlet - deploy
    java.io.FileNotFoundException: zimlet description not found: ZimbraPosixAccount.xml
    at com.zimbra.cs.zimlet.ZimletFile.initZimletDescript ion(ZimletFile.java:207)
    at com.zimbra.cs.zimlet.ZimletFile.initialize(ZimletF ile.java:199)
    at com.zimbra.cs.zimlet.ZimletFile.<init>(ZimletFile. java:154)
    at com.zimbra.cs.service.admin.DeployZimlet$DeployThr ead.run(DeployZimlet.java:99)
    at java.lang.Thread.run(Thread.java:595)
    ------------

    I tried modifying the zipfile at my (windows) desktop.
    I also tried it from scratch at the linux console. the same error

    in vi, config_template.xml lines are terminated by ^M (which I thought, were indicative of a windows file?)

    how am I supposed to edit the zipfile?

    btw: ZimbraPosixAccount.xml is present in the zipfile and untouched (as downloaded)

    regards
    glenn
    Last edited by glenndm; 07-31-2007 at 02:29 PM. Reason: extra info

  6. #6
    Join Date
    May 2007
    Posts
    98
    Rep Power
    8

    Default

    what a difference a day makes ... errm a good night's sleep actually

    re-reading the wiki document it finally dawned on me:
    the zimbra_posixaccount.zip file should only contain the files (8) in the zimbra_posixaccount folder and nothing else.

    Not as I thought yesterday: modify config_template.xml file and recreate the same zip file and structure as the downloaded file.

    the reward: the zimlet is succesfully deployed.

    away to the next stumbling block

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •