LDAP authentication admin console

General discussion about Zimbra Desktop.
User avatar
pup_seba
Outstanding Member
Outstanding Member
Posts: 687
Joined: Sat Sep 13, 2014 2:43 am
Location: Tarragona - Spain
Contact:

LDAP authentication admin console

Postby pup_seba » Tue Oct 06, 2015 6:58 am

Hi,



Hi! Domain LDAP authentication is configured for an external LDAP source (not AD). Users can validate with their external LDAP credentials but, admins can't login to the admin web console even when they can log in to their web client to check e-mails.


Any ideas what is happening? audit.log just says that there is an invalid log-in attempt. Mailbox.log says that externalldap user is missing.


CentOS 7.1 with Zimbra 8.6P3 FOSS.



Regards,



User avatar
pup_seba
Outstanding Member
Outstanding Member
Posts: 687
Joined: Sat Sep 13, 2014 2:43 am
Location: Tarragona - Spain
Contact:

LDAP authentication admin console

Postby pup_seba » Wed Oct 07, 2015 6:08 am

It works now. It turned out that there is a domain attribute named "zimbraAuthMechAdmin" which was configured to "ad" (i don't know why). I changed that to "ldap" and even without a service restart, admin console authentication works as expected now.



Hope this saves sometime to somebody :)



Regards!
seblu
Posts: 5
Joined: Sat Oct 06, 2018 1:52 pm

Re: LDAP authentication admin console

Postby seblu » Sun Apr 11, 2021 11:28 pm

5 years later I got into this. Thanks for sharing the solution! :)

Return to “General Questions”

Who is online

Users browsing this forum: Baidu [Spider] and 6 guests